aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-06-20 01:19:53 +0400
committerVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-06-20 01:19:53 +0400
commit159501c109f7100feb83457c6f23865ac31a71fc (patch)
tree95103ed7756f6863731b2ebd6557a8e2b5b4d655 /www-misc
parentwww-misc/libkiwix: new package (diff)
downloadguru-159501c109f7100feb83457c6f23865ac31a71fc.tar.gz
guru-159501c109f7100feb83457c6f23865ac31a71fc.tar.bz2
guru-159501c109f7100feb83457c6f23865ac31a71fc.zip
www-misc/kiwix-desktop: new package
Copy from https://data.gpo.zugaina.org/salfter/www-misc/kiwix-desktop Signed-off-by: Vitaly Zdanevich <zdanevich.vitaly@ya.ru>
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/kiwix-desktop/Manifest1
-rw-r--r--www-misc/kiwix-desktop/files/kiwix-desktop-2.3.1-shared_ptr.patch32
-rw-r--r--www-misc/kiwix-desktop/kiwix-desktop-2.3.1.ebuild38
-rw-r--r--www-misc/kiwix-desktop/metadata.xml11
4 files changed, 82 insertions, 0 deletions
diff --git a/www-misc/kiwix-desktop/Manifest b/www-misc/kiwix-desktop/Manifest
new file mode 100644
index 000000000..a3276a059
--- /dev/null
+++ b/www-misc/kiwix-desktop/Manifest
@@ -0,0 +1 @@
+DIST kiwix-desktop-2.3.1.tar.gz 525090 BLAKE2B 3f2bc6d49f383e754438dfee260b3aa1a09040b9b543b1abc8acc0aa4531e84c350e014f98951409b292ed7e9fa2285733d98237b0ff3b4175de8e8f269cac1f SHA512 09d4c2293fc36ac0b03c815474f5f60881093552fd7d1d0940858254c16d7b6021bd05f4f985b32401328705082f07fbd72e92f79bb1365650f5dd75d455f0b8
diff --git a/www-misc/kiwix-desktop/files/kiwix-desktop-2.3.1-shared_ptr.patch b/www-misc/kiwix-desktop/files/kiwix-desktop-2.3.1-shared_ptr.patch
new file mode 100644
index 000000000..668e38ca8
--- /dev/null
+++ b/www-misc/kiwix-desktop/files/kiwix-desktop-2.3.1-shared_ptr.patch
@@ -0,0 +1,32 @@
+From 1b322d8f01c787846546a6473f153cf1daa41e65 Mon Sep 17 00:00:00 2001
+From: Matthieu Gautier <mgautier@kymeria.fr>
+Date: Thu, 9 Feb 2023 09:47:47 +0100
+Subject: [PATCH] With last version of libkiwix, Downloader now return
+ shared_ptr<Download>.
+
+---
+ src/contentmanager.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/contentmanager.cpp b/src/contentmanager.cpp
+index c2f4ff98..d4db50a0 100644
+--- a/src/contentmanager.cpp
++++ b/src/contentmanager.cpp
+@@ -173,7 +173,7 @@ QStringList ContentManager::updateDownloadInfos(QString id, const QStringList &k
+ return values;
+ }
+ auto& b = mp_library->getBookById(id);
+- kiwix::Download* d;
++ std::shared_ptr<kiwix::Download> d;
+ try {
+ d = mp_downloader->getDownload(b.getDownloadId());
+ } catch(...) {
+@@ -270,7 +270,7 @@ QString ContentManager::downloadBook(const QString &id)
+ for (auto b : booksList)
+ if (b.toStdString() == book.getId())
+ return "";
+- kiwix::Download *download;
++ std::shared_ptr<kiwix::Download> download;
+ try {
+ std::pair<std::string, std::string> downloadDir("dir", downloadPath.toStdString());
+ const std::vector<std::pair<std::string, std::string>> options = { downloadDir };
diff --git a/www-misc/kiwix-desktop/kiwix-desktop-2.3.1.ebuild b/www-misc/kiwix-desktop/kiwix-desktop-2.3.1.ebuild
new file mode 100644
index 000000000..b3b4f168e
--- /dev/null
+++ b/www-misc/kiwix-desktop/kiwix-desktop-2.3.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+DESCRIPTION="cross-platform viewer/manager for ZIM archives"
+HOMEPAGE="https://kiwix.org/"
+SRC_URI="https://github.com/kiwix/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtimageformats:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebengine:5
+ =www-misc/libkiwix-12.1.0*:=
+
+"
+BDEPEND="app-arch/unzip"
+
+PATCHES=(
+ "${FILESDIR}/kiwix-desktop-2.3.1-shared_ptr.patch"
+)
+
+src_compile() {
+ eqmake5 PREFIX=/usr .
+ emake
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${ED}"
+}
diff --git a/www-misc/kiwix-desktop/metadata.xml b/www-misc/kiwix-desktop/metadata.xml
new file mode 100644
index 000000000..c5bf8d898
--- /dev/null
+++ b/www-misc/kiwix-desktop/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>zdanevich.vitaly@ya.ru</email>
+ <name>Vitaly Zdanevich</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">kiwix/kiwix-desktop</remote-id>
+ </upstream>
+</pkgmetadata>