aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README.md33
-rw-r--r--metadata/layout.conf2
-rw-r--r--net-im/nheko/Manifest3
-rw-r--r--net-im/nheko/nheko-9999.ebuild39
-rw-r--r--profiles/repo_name1
5 files changed, 76 insertions, 2 deletions
diff --git a/README.md b/README.md
index 3fb24de..8a9ab74 100644
--- a/README.md
+++ b/README.md
@@ -1,2 +1,31 @@
-# matrix-overlay
-Gentoo overlay containing clients and servers for the Matrix protocol
+# Matrix Gentoo overlay
+
+This Gentoo overlay contains clients and servers for the Matrix protocol
+
+## Installation
+
+Install this overlay like any other.
+
+* Install [`layman`](https://wiki.gentoo.org/wiki/Layman), Gentoo's official overlay manager.
+
+```
+# emerge --ask app-portage/layman
+```
+
+* Add the `matrix` overlay
+
+```
+# layman -a matrix
+```
+
+* Synchronize overlays
+
+```
+# layman -S
+```
+
+## Contributing
+
+Don't hesitate to create a PR for any other Matrix clients, servers and other services!
+
+You can report any ebuild issues or feature requests in the [issue tracker](https://github.com/puretryout/matrix-overlay/issues).
diff --git a/metadata/layout.conf b/metadata/layout.conf
new file mode 100644
index 0000000..c673a95
--- /dev/null
+++ b/metadata/layout.conf
@@ -0,0 +1,2 @@
+masters = gentoo
+auto-sync = false
diff --git a/net-im/nheko/Manifest b/net-im/nheko/Manifest
new file mode 100644
index 0000000..eadb5df
--- /dev/null
+++ b/net-im/nheko/Manifest
@@ -0,0 +1,3 @@
+DIST master.zip 4277168 SHA256 889fa8ec23672b382ea2effd8c221d5a1088304b091b8f1338b08ad11acba4ca SHA512 a3ca5166843b3bb3ec2fd1637032d9da9b2823f1f7f7a5db8a754af28423a98a99c2b3319cfeeb72d6cbbc59898c862d6ab97088d298953e4a1d8724f6a286ac WHIRLPOOL dab3d294df9f3323ba852a5916862c605f4dc2ba8035e4fd7bbeee2b72e3429163e2bdff7086bd0c070d315737b71bc3f87bdeb23e668217e16c582a77dc1da5
+EBUILD nheko-0.1.0.ebuild 355 SHA256 7bd1571f5aa6d6bbd970f056e77cd0ecfd3eb94452ba76857d0ad21f57c56d42 SHA512 a4d1546612b323bafe6369378606be550afca91e9fbf3a7d5e5bf9655c8e5a3d852470d0627bb87c4e224d22ec38d9569af38dac73e33a5c2186ec01bd622a91 WHIRLPOOL bf517256d1d7ec2f532f93375e7b8e6597e23ac3542806cf34b96a3e02dee2558c2e20611c9f32814c7dbe88fdf8c6f71238518f0b302a39b58ba2e389da3323
+EBUILD nheko-9999.ebuild 747 SHA256 c023c0464364ae5034ed96657214423ab0029a0016c9a77c7787d3b5f15af81d SHA512 9d08a859d2d3fd03a74c395fcc076136d1bb92589ab5e52ceee6587ec16cbd954835bf653e4f9080591940eb6b97ee62c4e2a4a285e2411210c37fa06ebd42c4 WHIRLPOOL e3ff5423e34aca6accfeaccc1f825a9897a8ddca75cccfc3d5573f43ded45f56ff0e86dfa5d01ead1c78ba8585d84c8c78f5c6d040d790f58e5b7f094362ce36
diff --git a/net-im/nheko/nheko-9999.ebuild b/net-im/nheko/nheko-9999.ebuild
new file mode 100644
index 0000000..338eb46
--- /dev/null
+++ b/net-im/nheko/nheko-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Desktop client for the Matrix protocol "
+HOMEPAGE="https://github.com/mujx/nheko"
+
+inherit git-r3 eutils
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/mujx/nheko.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-qt/qtgui
+ media-libs/fontconfig"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ ls /var/tmp/portage/net-im/nheko-9999/work/
+ cmake .
+ emake DESTDIR="${D}"
+}
+
+src_install() {
+ local icon_size
+ for icon_size in 16 32 48 64 128 256 512; do
+ newicon -s "${icon_size}" \
+ "${S}/resources/nheko-${icon_size}.png" \
+ nheko.png
+ done
+
+ domenu ${S}/resources/nheko.desktop
+
+ dobin nheko
+}
diff --git a/profiles/repo_name b/profiles/repo_name
new file mode 100644
index 0000000..f5f6bec
--- /dev/null
+++ b/profiles/repo_name
@@ -0,0 +1 @@
+matrix