summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2021-12-28 16:28:55 +0100
committerFabian Groffen <grobian@gentoo.org>2021-12-28 16:28:55 +0100
commitf7fb3c000689f3cd63cb8e3af8fb60b6088996d7 (patch)
tree3de67d725b981601edbae8ec52ffcbf582d057c3 /sys-apps
parentscripts/bootstrap-prefix: bump tree snapshot (diff)
downloadprefix-f7fb3c000689f3cd63cb8e3af8fb60b6088996d7.tar.gz
prefix-f7fb3c000689f3cd63cb8e3af8fb60b6088996d7.tar.bz2
prefix-f7fb3c000689f3cd63cb8e3af8fb60b6088996d7.zip
sys-apps/coreutils-9.0: fix/update stdbuf darwin bootstrap workaround
Package-Manager: Portage-3.0.21-prefix, Repoman-3.0.3 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/coreutils/coreutils-9.0-r2.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/sys-apps/coreutils/coreutils-9.0-r2.ebuild b/sys-apps/coreutils/coreutils-9.0-r2.ebuild
index 5d2550bf69..1774109986 100644
--- a/sys-apps/coreutils/coreutils-9.0-r2.ebuild
+++ b/sys-apps/coreutils/coreutils-9.0-r2.ebuild
@@ -84,16 +84,16 @@ src_prepare() {
# fixup libstdbuf non-libtool stuff
if [[ ${CHOST} == *-darwin* ]] ; then
- if [[ ${CHOST} == *-darwin9* ]] ; then
- # we need replacement libs from libcoreutils.a here in order
- # to finish the linking
- sed -i \
- -e "/src_libstdbuf_so_LDADD/s:$: lib/libcoreutils.a:" \
- Makefile.in \
- || die
- # and we need serial building :(
- export MAKEOPTS+=" -j1"
- fi
+ # we need replacement libs from libcoreutils.a here in order
+ # to finish the linking (they try to avoid this, but it doesn't
+ # during bootstrap, a re-install is fine though)
+ sed -i \
+ -e "/src_libstdbuf_so_LDADD/s:$: lib/libcoreutils.a:" \
+ Makefile.in \
+ || die
+ # and we need serial building :(
+ export MAKEOPTS+=" -j1"
+ # set a proper install_name
sed -i \
-e "/src_libstdbuf_so_LDFLAGS = -shared/s:-shared:-dynamiclib -install_name ${EPREFIX}/usr/libexec/coreutils/libstdbuf.dylib:" \
Makefile.in \