aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/pijul/pijul-0.12.2.ebuild')
-rw-r--r--dev-vcs/pijul/pijul-0.12.2.ebuild319
1 files changed, 319 insertions, 0 deletions
diff --git a/dev-vcs/pijul/pijul-0.12.2.ebuild b/dev-vcs/pijul/pijul-0.12.2.ebuild
new file mode 100644
index 0000000..32eb3be
--- /dev/null
+++ b/dev-vcs/pijul/pijul-0.12.2.ebuild
@@ -0,0 +1,319 @@
+# Copyright 2017-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Auto-Generated by cargo-ebuild 0.3.0
+
+EAPI=7
+
+CRATES="
+addr2line-0.12.1
+adler32-1.0.4
+advapi32-sys-0.2.0
+aho-corasick-0.7.10
+ansi_term-0.11.0
+arrayref-0.3.6
+arrayvec-0.5.1
+ascii-canvas-2.0.0
+atty-0.2.14
+autocfg-0.1.7
+autocfg-1.0.0
+backtrace-0.3.48
+base64-0.10.1
+base64-0.11.0
+base64-0.9.3
+bincode-1.2.1
+bindgen-0.51.1
+bit-set-0.5.2
+bit-vec-0.4.4
+bit-vec-0.6.2
+bitflags-1.2.1
+blake2b_simd-0.5.10
+block-buffer-0.7.3
+block-padding-0.1.5
+bs58-0.2.5
+bstr-0.2.13
+buffered-reader-0.9.0
+byte-tools-0.3.1
+byteorder-1.3.4
+bytes-0.4.12
+bzip2-0.3.3
+bzip2-sys-0.1.9+1.0.8
+cc-1.0.54
+cexpr-0.3.6
+cfg-if-0.1.10
+chrono-0.4.11
+clang-sys-0.28.1
+clap-2.33.1
+cloudabi-0.0.3
+constant_time_eq-0.1.5
+cookie-0.12.0
+cookie_store-0.7.0
+core-foundation-0.7.0
+core-foundation-sys-0.7.0
+crc32fast-1.2.0
+crossbeam-deque-0.7.3
+crossbeam-epoch-0.8.2
+crossbeam-queue-0.2.2
+crossbeam-utils-0.7.2
+cryptovec-0.4.6
+diff-0.1.12
+diffs-0.3.0
+digest-0.8.1
+dirs-1.0.5
+docopt-1.1.0
+dtoa-0.4.5
+either-1.5.3
+ena-0.13.1
+encoding_rs-0.8.23
+env_logger-0.6.2
+error-chain-0.12.2
+failure-0.1.8
+failure_derive-0.1.8
+fake-simd-0.1.2
+filetime-0.2.10
+fixedbitset-0.1.9
+flate2-1.0.14
+fnv-1.0.7
+foreign-types-0.3.2
+foreign-types-shared-0.1.1
+fs2-0.4.3
+fuchsia-cprng-0.1.1
+fuchsia-zircon-0.3.3
+fuchsia-zircon-sys-0.3.3
+futures-0.1.29
+futures-cpupool-0.1.8
+generic-array-0.12.3
+getch-0.2.1
+getrandom-0.1.14
+gimli-0.21.0
+glob-0.3.0
+globset-0.4.5
+h2-0.1.26
+hermit-abi-0.1.13
+hex-0.3.2
+http-0.1.21
+http-body-0.1.0
+httparse-1.3.4
+humantime-1.3.0
+hyper-0.12.35
+hyper-tls-0.3.2
+idna-0.1.5
+idna-0.2.0
+ignore-0.4.15
+indexmap-1.3.2
+iovec-0.1.4
+itertools-0.8.2
+itoa-0.4.5
+kernel32-sys-0.2.2
+lalrpop-0.17.2
+lalrpop-util-0.17.2
+lazy_static-1.4.0
+libc-0.2.71
+libloading-0.5.2
+libpijul-0.12.2
+line-0.1.15
+lock_api-0.3.4
+log-0.4.8
+mach_o_sys-0.1.1
+matches-0.1.8
+maybe-uninit-2.0.0
+memchr-2.3.3
+memmap-0.7.0
+memoffset-0.5.4
+memsec-0.5.7
+mime-0.3.16
+mime_guess-2.0.3
+miniz_oxide-0.3.6
+mio-0.6.22
+mio-uds-0.6.8
+miow-0.2.1
+native-tls-0.2.4
+net2-0.2.34
+nettle-5.0.3
+nettle-sys-2.0.4
+new_debug_unreachable-1.0.4
+nom-4.2.3
+num-0.1.42
+num-bigint-0.1.44
+num-complex-0.1.43
+num-integer-0.1.42
+num-iter-0.1.40
+num-rational-0.1.42
+num-traits-0.2.11
+num_cpus-1.13.0
+object-0.19.0
+opaque-debug-0.2.3
+openssl-0.10.29
+openssl-probe-0.1.2
+openssl-sys-0.9.57
+ordermap-0.3.5
+parking_lot-0.9.0
+parking_lot_core-0.6.2
+pathdiff-0.1.0
+peeking_take_while-0.1.2
+percent-encoding-1.0.1
+percent-encoding-2.1.0
+petgraph-0.4.13
+phf_generator-0.7.24
+phf_shared-0.7.24
+pijul-0.12.2
+pkg-config-0.3.17
+ppv-lite86-0.2.8
+precomputed-hash-0.1.1
+proc-macro2-1.0.17
+progrs-0.1.1
+publicsuffix-1.5.4
+quick-error-1.2.3
+quickcheck-0.8.5
+quote-1.0.6
+rand-0.4.6
+rand-0.6.5
+rand-0.7.3
+rand_chacha-0.1.1
+rand_chacha-0.2.2
+rand_core-0.3.1
+rand_core-0.4.2
+rand_core-0.5.1
+rand_hc-0.1.0
+rand_hc-0.2.0
+rand_isaac-0.1.1
+rand_jitter-0.1.4
+rand_os-0.1.3
+rand_pcg-0.1.2
+rand_xorshift-0.1.1
+rdrand-0.4.0
+redox_syscall-0.1.56
+redox_users-0.3.4
+regex-1.3.9
+regex-syntax-0.6.18
+remove_dir_all-0.5.2
+reqwest-0.9.24
+rpassword-2.1.0
+rust-argon2-0.7.0
+rustc-demangle-0.1.16
+rustc-hash-1.1.0
+rustc-serialize-0.3.24
+rustc_version-0.2.3
+ryu-1.0.4
+safemem-0.3.3
+same-file-1.0.6
+sanakirja-0.10.3
+schannel-0.1.19
+scopeguard-1.1.0
+security-framework-0.4.4
+security-framework-sys-0.4.3
+semver-0.9.0
+semver-parser-0.7.0
+sequoia-openpgp-0.9.0
+sequoia-rfc2822-0.9.0
+serde-1.0.110
+serde_derive-1.0.110
+serde_json-1.0.53
+serde_urlencoded-0.5.5
+sha2-0.8.2
+shell-escape-0.1.4
+shlex-0.1.1
+siphasher-0.2.3
+slab-0.4.2
+smallvec-0.6.13
+smallvec-1.4.0
+string-0.2.1
+string_cache-0.7.5
+string_cache_codegen-0.4.4
+string_cache_shared-0.3.0
+strsim-0.8.0
+strsim-0.9.3
+syn-1.0.27
+synstructure-0.12.3
+tar-0.4.28
+tempdir-0.3.7
+tempfile-3.1.0
+term-0.5.2
+termcolor-1.1.0
+termios-0.2.2
+textwrap-0.11.0
+thread_local-1.0.1
+thrussh-0.21.5
+thrussh-config-0.2.0
+thrussh-keys-0.11.9
+thrussh-libsodium-0.1.4
+time-0.1.43
+tokio-0.1.22
+tokio-buf-0.1.1
+tokio-codec-0.1.2
+tokio-current-thread-0.1.7
+tokio-executor-0.1.10
+tokio-fs-0.1.7
+tokio-io-0.1.13
+tokio-reactor-0.1.12
+tokio-sync-0.1.8
+tokio-tcp-0.1.4
+tokio-threadpool-0.1.18
+tokio-timer-0.2.13
+tokio-udp-0.1.6
+tokio-uds-0.2.6
+toml-0.4.10
+try-lock-0.2.2
+try_from-0.3.2
+typenum-1.12.0
+unicase-2.6.0
+unicode-bidi-0.3.4
+unicode-normalization-0.1.12
+unicode-width-0.1.7
+unicode-xid-0.1.0
+unicode-xid-0.2.0
+url-1.7.2
+url-2.1.1
+username-0.2.0
+utf8parse-0.1.1
+uuid-0.7.4
+vcpkg-0.2.8
+vec_map-0.8.2
+version_check-0.1.5
+version_check-0.9.2
+walkdir-2.3.1
+want-0.2.0
+wasi-0.9.0+wasi-snapshot-preview1
+winapi-0.2.8
+winapi-0.3.8
+winapi-build-0.1.1
+winapi-i686-pc-windows-gnu-0.4.0
+winapi-util-0.1.5
+winapi-x86_64-pc-windows-gnu-0.4.0
+winreg-0.6.2
+ws2_32-sys-0.2.1
+xattr-0.2.2
+yasna-0.1.3
+"
+
+inherit cargo llvm
+
+DESCRIPTION="Distributed VCS based on a sound theory of patches."
+HOMEPAGE="https://pijul.org/"
+SRC_URI="$(cargo_crate_uris ${CRATES})"
+RESTRICT="mirror"
+# License set may be more restrictive as OR is not respected
+# use cargo-license for a more accurate license picture
+LICENSE="Apache-2.0 Apache-2.0 WITH LLVM-exception BSD-2-Clause BSD-3-Clause BSL-1.0 CC0-1.0 GPL-2.0 GPL-2.0+ GPL-3.0 ISC LGPL-3.0 MIT Unlicense Zlib"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libsodium
+ dev-libs/nettle
+ dev-libs/openssl:0="
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-ssh-location.patch"
+)
+
+src_compile() {
+ local LLVM_CONFIG_PATH="$(get_llvm_prefix "${LLVM_MAX_SLOT}")/bin/llvm-config"
+ export LIBCLANG_PATH=$(${LLVM_CONFIG_PATH} --libdir)
+ cargo_src_compile
+}
+
+src_install() {
+ cargo_src_install --no-track
+}