summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-28 23:24:40 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-28 23:40:54 +0200
commit8254d8e41b4915e04c949e1d22946c8529995943 (patch)
tree466b891194894ea91b396fbe52877ba76903ae99 /app-benchmarks/httperf/httperf-0.9.1_p20181111.ebuild
parentnet-misc/stuntman: 1.2.15 version bump, add missing openssl slot op (diff)
downloadgentoo-8254d8e41b4915e04c949e1d22946c8529995943.tar.gz
gentoo-8254d8e41b4915e04c949e1d22946c8529995943.tar.bz2
gentoo-8254d8e41b4915e04c949e1d22946c8529995943.zip
app-benchmarks/httperf: Add 0.9.1_p20181111 snapshot
Fixes build with >=dev-libs/openssl-1.1 Thanks-to: Jan Ziak <0xe2.0x9a.0x9b@gmail.com> Closes: https://bugs.gentoo.org/674582 Package-Manager: Portage-2.3.65, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-benchmarks/httperf/httperf-0.9.1_p20181111.ebuild')
-rw-r--r--app-benchmarks/httperf/httperf-0.9.1_p20181111.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-benchmarks/httperf/httperf-0.9.1_p20181111.ebuild b/app-benchmarks/httperf/httperf-0.9.1_p20181111.ebuild
new file mode 100644
index 000000000000..75a84f5332ab
--- /dev/null
+++ b/app-benchmarks/httperf/httperf-0.9.1_p20181111.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+COMMIT="00bf5dab6fd284aa559f125964f5fe6dc0f23595"
+inherit autotools
+
+DESCRIPTION="A tool from HP for measuring web server performance"
+HOMEPAGE="https://github.com/httperf/httperf"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+-with-openssl-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86 ~amd64-linux ~x64-macos"
+IUSE="debug idleconn libressl"
+
+DEPEND="
+ idleconn? ( dev-libs/libevent:0= )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --bindir="${EPREFIX}"/usr/bin
+ $(use_enable debug)
+ $(use_enable idleconn)
+ )
+
+ econf "${myeconfargs[@]}"
+}