summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/nibbles
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/nibbles')
-rw-r--r--games-arcade/nibbles/Manifest1
-rw-r--r--games-arcade/nibbles/files/nibbles-0.0.4-as-needed.patch24
-rw-r--r--games-arcade/nibbles/metadata.xml5
-rw-r--r--games-arcade/nibbles/nibbles-0.0.4.ebuild49
4 files changed, 79 insertions, 0 deletions
diff --git a/games-arcade/nibbles/Manifest b/games-arcade/nibbles/Manifest
new file mode 100644
index 000000000000..c05b9b4296c3
--- /dev/null
+++ b/games-arcade/nibbles/Manifest
@@ -0,0 +1 @@
+DIST nibbles-v0.0.4.tar.gz 18610 SHA256 4a1715d700319fdad55f8e880d68a16399f9bf1a35ab403f03c13286cd50ee92 SHA512 a10af4f20af371c2a8ab4cf69c4a73120670815467177d3bc2a05aa198e9edf80cc1d47edf40d06059baf6e51cf7018ed4830a3a5bda6a35868548403f5f414b WHIRLPOOL c6900db02529c8a352894e0dca63adb276f6a61e9babef3d2e8a21fa82e4740a82a26c2f090412858feae18ccd7bce16cf2feed502f48cd55820a35d7f0fd3fa
diff --git a/games-arcade/nibbles/files/nibbles-0.0.4-as-needed.patch b/games-arcade/nibbles/files/nibbles-0.0.4-as-needed.patch
new file mode 100644
index 000000000000..7e27d1fb9cac
--- /dev/null
+++ b/games-arcade/nibbles/files/nibbles-0.0.4-as-needed.patch
@@ -0,0 +1,24 @@
+--- Makefile.old 2009-02-02 12:40:36.000000000 +0100
++++ Makefile 2009-02-02 12:41:22.000000000 +0100
+@@ -1,19 +1,14 @@
+-CC = gcc -Wall -g
+-
+ SRCS = player.c main.c loadMap.c cmdline.c ncdrawlib.c scoring.c
+ OBJS = $(SRCS:.c=.o)
+-LIBS = -lncurses
++LDLIBS = -lncurses
+
+ INSTALL=/usr/bin/install -c
+ INSTALL_FOLDER=/usr/games
+
+ all: nibbles
+
+-.c.o:
+- $(CC) -c $*.c -o $*.o
+-
+ nibbles: $(OBJS)
+- $(CC) $(LIBS) $(OBJS) -o $@
++ $(CC) $(LDFLAGS) $(OBJS) $(LDLIBS) -o $@
+
+ clean:
+ rm -f *~ *.o nibbles
diff --git a/games-arcade/nibbles/metadata.xml b/games-arcade/nibbles/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/nibbles/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-arcade/nibbles/nibbles-0.0.4.ebuild b/games-arcade/nibbles/nibbles-0.0.4.ebuild
new file mode 100644
index 000000000000..95e45f240207
--- /dev/null
+++ b/games-arcade/nibbles/nibbles-0.0.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+MY_P=${PN}-v${PV}
+DESCRIPTION="An ncurses-based Nibbles clone"
+HOMEPAGE="http://www.earth.li/projectpurple/progs/nibbles.html"
+SRC_URI="http://www.earth.li/projectpurple/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i \
+ -e "s#/usr/local/games/nibbles.levels#${GAMES_DATADIR}/${PN}#" \
+ nibbles.h || die
+
+ sed -i \
+ -e "s#/var/lib/games/nibbles.score#${GAMES_STATEDIR}/nibbles.scores#" \
+ scoring.h || die
+
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+}
+
+src_install() {
+ dogamesbin nibbles
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins nibbles.levels/*
+
+ dodir "${GAMES_STATEDIR}"
+ touch "${D}${GAMES_STATEDIR}/nibbles.scores"
+
+ dodoc HISTORY CREDITS TODO README
+
+ prepgamesdirs
+
+ fperms 664 "${GAMES_STATEDIR}/nibbles.scores"
+}