summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-03-03 13:47:51 -0300
committerPacho Ramos <pacho@gentoo.org>2024-07-16 12:55:04 +0200
commit80283c533f50a755a3fa2bf339a15d3551da3fda (patch)
tree5a1823fa3fe58afa86987b87ac072c96b7582f12 /games-puzzle
parentdev-java/gson: restrict to >=virtual/jdk-11 #936143 (diff)
downloadgentoo-80283c533f50a755a3fa2bf339a15d3551da3fda.tar.gz
gentoo-80283c533f50a755a3fa2bf339a15d3551da3fda.tar.bz2
gentoo-80283c533f50a755a3fa2bf339a15d3551da3fda.zip
games-puzzle/swell-foop: Bump to 46.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/36860 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/swell-foop/Manifest1
-rw-r--r--games-puzzle/swell-foop/swell-foop-46.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/games-puzzle/swell-foop/Manifest b/games-puzzle/swell-foop/Manifest
index 0e7785e2bd4f..dc2f0fd2818e 100644
--- a/games-puzzle/swell-foop/Manifest
+++ b/games-puzzle/swell-foop/Manifest
@@ -1 +1,2 @@
DIST swell-foop-41.1.tar.xz 832672 BLAKE2B 97908acab3bc565f084d97b02f8a6200dc170bd1bdb87ebc4e027881aa75a5111e3ecd24594395266fdfdab586a328df9d15fa8d25105529ec571b36f4fa0e5f SHA512 811638d9b09d7aaa584e56def47900bc866b56ac59120a1df91130f7a6b9555befd18907647874fd69dfa0992cee1c6320dc2bc684b3e5f05f6a25a791ac0a60
+DIST swell-foop-46.0.tar.xz 869096 BLAKE2B dccae8be0223726586c002c4a1752e5fd0162b31f91e9e739a76adc5599ee3b6d2f069654e1463dc16ecd537cb3e836d2f0a2fed93a840e75f5f021284005143 SHA512 01cb51635f78cb860cc967bcf54089f385d16cc1d64e209f21906acb04b86a1eb83951eb6fedc71b5fc3cdfb15947da9527ac087ea9b50112086679816bb4c7c
diff --git a/games-puzzle/swell-foop/swell-foop-46.0.ebuild b/games-puzzle/swell-foop/swell-foop-46.0.ebuild
new file mode 100644
index 000000000000..e3a96c478496
--- /dev/null
+++ b/games-puzzle/swell-foop/swell-foop-46.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Clear the screen by removing groups of colored and shaped tiles"
+HOMEPAGE="https://wiki.gnome.org/Apps/Swell%20Foop"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.74:2
+ >=gui-libs/gtk-4.10:4
+ >=dev-libs/libgnome-games-support-2.0.0:2=
+ >=gnome-base/librsvg-2.46
+ >=dev-libs/libgee-0.14.0:0.8=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}