summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Persson Forsberg <cat@catcream.org>2024-09-05 21:12:14 +0200
committerSam James <sam@gentoo.org>2024-09-05 20:17:50 +0100
commit44b6acd83b85c35f94cbbf686ddbc2e5c8011693 (patch)
tree3e7c6dcab894d98f33bf86b412cbce8ba45c9687 /net-irc
parentwww-servers/tomcat: Stabilize 10.1.28 amd64, #939126 (diff)
downloadgentoo-44b6acd83b85c35f94cbbf686ddbc2e5c8011693.tar.gz
gentoo-44b6acd83b85c35f94cbbf686ddbc2e5c8011693.tar.bz2
gentoo-44b6acd83b85c35f94cbbf686ddbc2e5c8011693.zip
net-irc/soju: drop 0.7.0-r1
Signed-off-by: Alfred Persson Forsberg <cat@catcream.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/soju/Manifest2
-rw-r--r--net-irc/soju/soju-0.7.0-r1.ebuild74
2 files changed, 0 insertions, 76 deletions
diff --git a/net-irc/soju/Manifest b/net-irc/soju/Manifest
index ee3b47f0067c..42b20a9d03d9 100644
--- a/net-irc/soju/Manifest
+++ b/net-irc/soju/Manifest
@@ -1,4 +1,2 @@
-DIST soju-0.7.0-deps.tar.xz 89862684 BLAKE2B d56302c5b330c581365da56f1718571144ac0475fa5879a839e723d2d13aa6cb9793a8f64418098aa0035421192eb2ae955603330ea3be6116db057d5fef3b1a SHA512 08fb5f2e75508840b76fb5f3479023eb735abc128cef0a621a3bafbc8d1dde504cf78812cb4e7921d7aaaafc40595ca592ce0b8aaf21c388fd781b52b5d266d2
-DIST soju-0.7.0.tar.gz 149198 BLAKE2B 2047b61792454f20a7cc4c24466047ffa43f5d56a1726b32f5120686d5fecd1f81d057adafc8696e2d85e922e37ae6f158808c0b35529ca2cb7018ecbec0d381 SHA512 9b199c5e3270e325cb6e101b0e7b5c70af75c831442a135fa0484bd2aef3ada98ab48261cd91342d278bfbbbbb626c2c83eeec8029388a8fe9663515e676ba43
DIST soju-0.8.0-deps.tar.xz 79434480 BLAKE2B 4cb3bbcd7d4c0fc610dffc585291fe07981c0d5d08e81fe800c6a08f3655eb999e097e17fe59342b896091a8e5640782f65bba351b94948ff9ed0f548fe6280c SHA512 a1f82740e673ed95cde2917d5dad53645b8cfcdefd673f44cd5b0573238c39a17355ea27e55572bb03625529202be50bf00f4bb57322ffa8857409cb1b190872
DIST soju-0.8.0.tar.gz 154571 BLAKE2B 737fc3e44ea04b42c6a5029db0c6c65a03c22dd30c26196439c97abe2ee9f1379b9cd49ef2cf15e25a911c0d05af1f17fcfea585c85278e081e4f3b7d9d55342 SHA512 22fb0815704b70dd302d75c4a00d80ac22cd622175066e7365277ef7d5a531537aa308b53703d15651a5ae841e2a02a3d7f19165c847078c5a0ae3c40d750738
diff --git a/net-irc/soju/soju-0.7.0-r1.ebuild b/net-irc/soju/soju-0.7.0-r1.ebuild
deleted file mode 100644
index 43d0b770ae70..000000000000
--- a/net-irc/soju/soju-0.7.0-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-EAPI=8
-
-inherit go-module systemd
-
-DESCRIPTION="soju is a user-friendly IRC bouncer"
-HOMEPAGE="https://soju.im/"
-SRC_URI="https://git.sr.ht/~emersion/${PN}/refs/download/v${PV}/${P}.tar.gz"
-SRC_URI+=" https://github.com/alfredfo/${PN}-deps/raw/master/${P}-deps.tar.xz"
-
-LICENSE="AGPL-3 Apache-2.0 MIT BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
-IUSE="moderncsqlite +sqlite pam"
-REQUIRED_USE="?? ( moderncsqlite sqlite )"
-
-BDEPEND="
- app-text/scdoc
-"
-RDEPEND="
- acct-user/soju
- acct-group/soju
- sqlite? ( dev-db/sqlite:3 )
-"
-DEPEND="${RDEPEND}"
-
-src_compile() {
- # musl removed legacy LFS64 interfaces in version 1.2.4 temporarily
- # reenabled using _LARGEFILE64_SOURCE until this is resolved
- # upstream https://github.com/mattn/go-sqlite3/issues/1164
- CGO_CFLAGS="${CGO_CFLAGS}"
- if use sqlite; then
- GOFLAGS+=" -tags=libsqlite3"
- CGO_CFLAGS="-D_LARGEFILE64_SOURCE"
- elif use moderncsqlite; then
- GOFLAGS+=" -tags=moderncsqlite"
- CGO_CFLAGS="-D_LARGEFILE64_SOURCE"
- else
- GOFLAGS+=" -tags=nosqlite"
- fi
- # Only way to pass CFLAGS to CGO at the
- # moment. https://github.com/gentoo/gentoo/pull/33539/
- export CGO_CFLAGS
- use pam && GOFLAGS+=" -tags=pam"
-
- ego build ${GOFLAGS} ./cmd/soju
- ego build ${GOFLAGS} ./cmd/sojudb
- ego build ${GOFLAGS} ./cmd/sojuctl
-
- scdoc <doc/soju.1.scd >doc/soju.1 || die
- scdoc <doc/sojuctl.1.scd >doc/sojuctl.1 || die
-}
-
-src_install() {
- dobin soju
- dobin sojudb
- dobin sojuctl
-
- doman doc/soju.1
- doman doc/sojuctl.1
- systemd_dounit contrib/soju.service
- keepdir /etc/soju
- insinto /etc/soju
- newins config.in config
- newinitd "${FILESDIR}"/soju.initd soju
- einstalldocs
-}
-
-pkg_postinst() {
- elog "${PN} requires a user database for authenticating clients."
- elog "As the soju user, create a database using:"
- elog "$ sojudb -config ${EROOT}/etc/soju/config create-user <username> [-admin]"
-}