summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris, Jr. <johnmh@johnmh.me>2024-06-16 20:50:55 -0700
committerJohn M. Harris, Jr. <johnmh@johnmh.me>2024-06-16 20:50:55 -0700
commit80a6de2ba2e5e27334ab1ef1014612a48a565627 (patch)
tree9447fe183656e3e0f1cf466a06659fdde9a4ade8
parentgui-libs/hyprcursor: Update manifest (diff)
downloadjohnmh-80a6de2ba2e5e27334ab1ef1014612a48a565627.tar.gz
johnmh-80a6de2ba2e5e27334ab1ef1014612a48a565627.tar.bz2
johnmh-80a6de2ba2e5e27334ab1ef1014612a48a565627.zip
gui-libs/hyprutils: Add ebuild
Signed-off-by: John M. Harris, Jr. <johnmh@johnmh.me>
-rw-r--r--gui-libs/hyprutils/Manifest1
-rw-r--r--gui-libs/hyprutils/hyprutils-9999.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/gui-libs/hyprutils/Manifest b/gui-libs/hyprutils/Manifest
new file mode 100644
index 0000000..e9f1c75
--- /dev/null
+++ b/gui-libs/hyprutils/Manifest
@@ -0,0 +1 @@
+EBUILD hyprutils-9999.ebuild 760 BLAKE2B 174cf25662c56bc8f06db1be515263b295ddf47ed64cbae50576631936505bdee00a02068d9410455b14e300b7ea55cfe8018624057e0c81084bf0b703bc3093 SHA512 a7ab08a166068d32d058eceedf79ffd9084fa9d43e6438475dc3be5487d0618697a732423bb92036dcee9f286974b0a3a2b0e38fa9e5f8fd5cff83e8300cd1f0
diff --git a/gui-libs/hyprutils/hyprutils-9999.ebuild b/gui-libs/hyprutils/hyprutils-9999.ebuild
new file mode 100644
index 0000000..f58baa5
--- /dev/null
+++ b/gui-libs/hyprutils/hyprutils-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023-2024 Gentoo Authors
+# Copyright 2024 John M. Harris, Jr.
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Hyprland utilities library used across the ecosystem"
+HOMEPAGE="https://github.com/hyprwm/hyprutils"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN^}.git"
+else
+ SRC_URI="https://github.com/hyprwm/${PN^}/releases/download/v${PV}/source-v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${PN}-source"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+# Disable tests since as per upstream, tests require a theme to be installed
+# See also https://github.com/hyprwm/hyprcursor/commit/94361fd8a75178b92c4bb24dcd8c7fac8423acf3
+RESTRICT="test"