aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel Bernardo <samuelbernardo.mail@gmail.com>2021-06-26 15:40:30 +0100
committerSamuel Bernardo <samuelbernardo.mail@gmail.com>2021-06-26 15:40:30 +0100
commit949ae6697e1e02349162d3e47997ac596d76f07b (patch)
tree738e61c9e7138c004fe7c72a6d361b5e7696604e /dev-java
parentUpdate visual-studio-code manifest (diff)
downloadssnb-949ae6697e1e02349162d3e47997ac596d76f07b.tar.gz
ssnb-949ae6697e1e02349162d3e47997ac596d76f07b.tar.bz2
ssnb-949ae6697e1e02349162d3e47997ac596d76f07b.zip
Correct QA check errors in cache regen
Signed-off-by: Samuel Bernardo <samuelbernardo.mail@gmail.com>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/nexus-oss-bin/nexus-oss-bin-3.14.0-r1.ebuild88
-rw-r--r--dev-java/nexus-oss-bin/nexus-oss-bin-3.14.0.ebuild72
-rw-r--r--dev-java/nexus-oss-bin/nexus-oss-bin-3.7.0.ebuild72
3 files changed, 0 insertions, 232 deletions
diff --git a/dev-java/nexus-oss-bin/nexus-oss-bin-3.14.0-r1.ebuild b/dev-java/nexus-oss-bin/nexus-oss-bin-3.14.0-r1.ebuild
deleted file mode 100644
index 25692cb..0000000
--- a/dev-java/nexus-oss-bin/nexus-oss-bin-3.14.0-r1.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-
-inherit eutils user versionator systemd
-
-DESCRIPTION="Maven Repository Manager"
-HOMEPAGE="http://nexus.sonatype.org/"
-LICENSE="GPL-3"
-MY_PN="nexus"
-MY_PV="${PV}-04-unix"
-#echo "Debug: custom package version: ${MY_PV}"
-MY_P="${MY_PN}-${MY_PV}"
-MY_MV="3"
-
-SRC_URI="http://download.sonatype.com/${MY_PN}/${MY_MV}/${MY_P}.tar.gz"
-RESTRICT="mirror"
-KEYWORDS="~x86 ~amd64"
-SLOT="${MY_MV}"
-IUSE=""
-S="${WORKDIR}"
-#echo "Debug: working directory: ${WORKDIR}"
-RDEPEND=">=virtual/jdk-1.8"
-INSTALL_DIR="/opt/nexus-oss"
-
-pkg_setup() {
-#enewgroup <name> [gid]
-enewgroup nexus
-#enewuser <user> [uid] [shell] [homedir] [groups] [params]
-enewuser nexus -1 /bin/bash "${INSTALL_DIR}" "nexus"
-}
-
-src_unpack() {
-unpack ${A}
-}
-
-src_prepare() {
-cd "${S}"
-if -f "${FILESDIR}/${P}.patch"; then
- epatch "${FILESDIR}/${P}.patch"
-fi
-epatch_user
-}
-
-src_install() {
-#echo "Debug: install sonatype work dir"
-dodir ${INSTALL_DIR/nexus-oss/sonatype-work}
-insinto ${INSTALL_DIR/nexus-oss/sonatype-work}
-doins -r sonatype-work/*
-
-fowners -R nexus:nexus ${INSTALL_DIR/nexus-oss/sonatype-work}
-
-#echo "Debug: INSTALL_DIR: ${INSTALL_DIR}"
-#echo "Debug: doins nexus-${MY_PV}"
-#echo "Debug: ${WORKDIR}/nexus-${MY_PV}/bin/nexus"
-insinto ${INSTALL_DIR}
-
-dodir ${INSTALL_DIR}/run
-dodir "/etc/init.d/"
-doins -r ${MY_P/-unix/}/*
-doins -r ${MY_P/-unix/}/.??*
-#BUG: nexus init script needs a symlink because it uses program path to find their configuration files
-#newinitd "${WORKDIR}/nexus-${MY_PV}/bin/nexus" nexus
-dosym ${INSTALL_DIR}/bin/nexus /etc/init.d/nexus
-systemd_dounit "${FILESDIR}"/nexus-oss.service
-
-fowners -R nexus:nexus ${INSTALL_DIR}
-fperms 755 "${INSTALL_DIR}/bin/nexus"
-
-#echo "Change NEXUS_HOME to the absolute folder location in your .bashrc file, then save"
-echo NEXUS_HOME=\"${INSTALL_DIR}\" >> ${ED}/${INSTALL_DIR}/.bashrc
-fowners -R nexus:nexus ${INSTALL_DIR}/.bashrc
-fperms 644 ${INSTALL_DIR}/.bashrc
-}
-
-pkg_postinst() {
- ewarn "Activate the service with the following commands:"
- ewarn "sudo systemctl daemon-reload"
- ewarn "sudo systemctl enable nexus-oss.service"
- ewarn "sudo systemctl start nexus-oss.service"
- ewarn " "
- elog "After starting the service in Gentoo, verify that"
- elog "the service started successfully."
- elog "tail -f /opt/sonatype-work/nexus3/log/nexus.log"
-}
-
diff --git a/dev-java/nexus-oss-bin/nexus-oss-bin-3.14.0.ebuild b/dev-java/nexus-oss-bin/nexus-oss-bin-3.14.0.ebuild
deleted file mode 100644
index abeff12..0000000
--- a/dev-java/nexus-oss-bin/nexus-oss-bin-3.14.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-
-inherit eutils user versionator systemd
-
-DESCRIPTION="Maven Repository Manager"
-HOMEPAGE="http://nexus.sonatype.org/"
-LICENSE="GPL-3"
-MY_PN="nexus"
-MY_PV="${PV}-04-unix"
-#echo "Debug: custom package version: ${MY_PV}"
-MY_P="${MY_PN}-${MY_PV}"
-MY_MV="3"
-
-SRC_URI="http://download.sonatype.com/${MY_PN}/${MY_MV}/${MY_P}.tar.gz"
-RESTRICT="mirror"
-KEYWORDS="~x86 ~amd64"
-SLOT="${MY_MV}"
-IUSE=""
-S="${WORKDIR}"
-#echo "Debug: working directory: ${WORKDIR}"
-RDEPEND=">=virtual/jdk-1.8"
-INSTALL_DIR="/opt/nexus-oss"
-
-pkg_setup() {
-#enewgroup <name> [gid]
-enewgroup nexus
-#enewuser <user> [uid] [shell] [homedir] [groups] [params]
-enewuser nexus -1 /bin/bash "${INSTALL_DIR}" "nexus"
-}
-
-src_unpack() {
-unpack ${A}
-}
-
-src_prepare() {
-cd "${S}"
-if -f "${FILESDIR}/${P}.patch"; then
- epatch "${FILESDIR}/${P}.patch"
-fi
-epatch_user
-}
-
-src_install() {
-#echo "Debug: install sonatype work dir"
-dodir ${INSTALL_DIR/nexus-oss/sonatype-work}
-insinto ${INSTALL_DIR/nexus-oss/sonatype-work}
-doins -r sonatype-work/*
-
-fowners -R nexus:nexus ${INSTALL_DIR/nexus-oss/sonatype-work}
-
-#echo "Debug: INSTALL_DIR: ${INSTALL_DIR}"
-#echo "Debug: doins nexus-${MY_PV}"
-#echo "Debug: ${WORKDIR}/nexus-${MY_PV}/bin/nexus"
-insinto ${INSTALL_DIR}
-
-dodir ${INSTALL_DIR}/run
-dodir "/etc/init.d/"
-doins -r ${MY_P/-unix/}/*
-doins -r ${MY_P/-unix/}/.??*
-#BUG: nexus init script needs a symlink because it uses program path to find their configuration files
-#newinitd "${WORKDIR}/nexus-${MY_PV}/bin/nexus" nexus
-dosym ${INSTALL_DIR}/bin/nexus /etc/init.d/nexus
-systemd_dounit "${FILESDIR}"/nexus-oss.service
-
-fowners -R nexus:nexus ${INSTALL_DIR}
-fperms 755 "${INSTALL_DIR}/bin/nexus"
-
-}
diff --git a/dev-java/nexus-oss-bin/nexus-oss-bin-3.7.0.ebuild b/dev-java/nexus-oss-bin/nexus-oss-bin-3.7.0.ebuild
deleted file mode 100644
index abeff12..0000000
--- a/dev-java/nexus-oss-bin/nexus-oss-bin-3.7.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-
-inherit eutils user versionator systemd
-
-DESCRIPTION="Maven Repository Manager"
-HOMEPAGE="http://nexus.sonatype.org/"
-LICENSE="GPL-3"
-MY_PN="nexus"
-MY_PV="${PV}-04-unix"
-#echo "Debug: custom package version: ${MY_PV}"
-MY_P="${MY_PN}-${MY_PV}"
-MY_MV="3"
-
-SRC_URI="http://download.sonatype.com/${MY_PN}/${MY_MV}/${MY_P}.tar.gz"
-RESTRICT="mirror"
-KEYWORDS="~x86 ~amd64"
-SLOT="${MY_MV}"
-IUSE=""
-S="${WORKDIR}"
-#echo "Debug: working directory: ${WORKDIR}"
-RDEPEND=">=virtual/jdk-1.8"
-INSTALL_DIR="/opt/nexus-oss"
-
-pkg_setup() {
-#enewgroup <name> [gid]
-enewgroup nexus
-#enewuser <user> [uid] [shell] [homedir] [groups] [params]
-enewuser nexus -1 /bin/bash "${INSTALL_DIR}" "nexus"
-}
-
-src_unpack() {
-unpack ${A}
-}
-
-src_prepare() {
-cd "${S}"
-if -f "${FILESDIR}/${P}.patch"; then
- epatch "${FILESDIR}/${P}.patch"
-fi
-epatch_user
-}
-
-src_install() {
-#echo "Debug: install sonatype work dir"
-dodir ${INSTALL_DIR/nexus-oss/sonatype-work}
-insinto ${INSTALL_DIR/nexus-oss/sonatype-work}
-doins -r sonatype-work/*
-
-fowners -R nexus:nexus ${INSTALL_DIR/nexus-oss/sonatype-work}
-
-#echo "Debug: INSTALL_DIR: ${INSTALL_DIR}"
-#echo "Debug: doins nexus-${MY_PV}"
-#echo "Debug: ${WORKDIR}/nexus-${MY_PV}/bin/nexus"
-insinto ${INSTALL_DIR}
-
-dodir ${INSTALL_DIR}/run
-dodir "/etc/init.d/"
-doins -r ${MY_P/-unix/}/*
-doins -r ${MY_P/-unix/}/.??*
-#BUG: nexus init script needs a symlink because it uses program path to find their configuration files
-#newinitd "${WORKDIR}/nexus-${MY_PV}/bin/nexus" nexus
-dosym ${INSTALL_DIR}/bin/nexus /etc/init.d/nexus
-systemd_dounit "${FILESDIR}"/nexus-oss.service
-
-fowners -R nexus:nexus ${INSTALL_DIR}
-fperms 755 "${INSTALL_DIR}/bin/nexus"
-
-}