aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel Bernardo <samuelbernardo.mail@gmail.com>2020-05-10 23:09:59 +0100
committerSamuel Bernardo <samuelbernardo.mail@gmail.com>2020-05-10 23:09:59 +0100
commit2e14962dabb01503d6aea3292d4c0e66f1ec78c7 (patch)
tree4ae69508c3783b8f335c02e2ab6c61b37f1bd382 /dev-nodejs/grunt/grunt-1.0.2.ebuild
parentCorrect npm eclass to set lib as demanded by Gentoo environment (diff)
downloadssnb-2e14962dabb01503d6aea3292d4c0e66f1ec78c7.tar.gz
ssnb-2e14962dabb01503d6aea3292d4c0e66f1ec78c7.tar.bz2
ssnb-2e14962dabb01503d6aea3292d4c0e66f1ec78c7.zip
Correct opennebula ebuild to build sunstone minified files
Signed-off-by: Samuel Bernardo <samuelbernardo.mail@gmail.com>
Diffstat (limited to 'dev-nodejs/grunt/grunt-1.0.2.ebuild')
-rw-r--r--dev-nodejs/grunt/grunt-1.0.2.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-nodejs/grunt/grunt-1.0.2.ebuild b/dev-nodejs/grunt/grunt-1.0.2.ebuild
index 6ce501d..8b5c929 100644
--- a/dev-nodejs/grunt/grunt-1.0.2.ebuild
+++ b/dev-nodejs/grunt/grunt-1.0.2.ebuild
@@ -29,3 +29,8 @@ RDEPEND="dev-nodejs/grunt-cli
dev-nodejs/eventemitter2
dev-nodejs/dateformat
dev-nodejs/coffeescript"
+
+src_prepare() {
+ default
+ sed -i -e "s|grunt-cli/bin/grunt|../$(get_libdir)/node_modules/grunt-cli/bin/grunt|" "bin/${NPM_BIN}" || die "Failed to correct path for grunt-cli lib"
+}