summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/subdownloader/subdownloader-2.0.18-r1.ebuild')
-rw-r--r--media-video/subdownloader/subdownloader-2.0.18-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-video/subdownloader/subdownloader-2.0.18-r1.ebuild b/media-video/subdownloader/subdownloader-2.0.18-r1.ebuild
new file mode 100644
index 0000000..cc8a836
--- /dev/null
+++ b/media-video/subdownloader/subdownloader-2.0.18-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 eutils
+
+DESCRIPTION="GUI application for automatic downloading/uploading of subtitles for videofiles"
+HOMEPAGE="http://www.subdownloader.net/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${PN}_2.0.18.orig.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ dev-python/PyQt4
+ dev-python/kaa-metadata"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ python_fix_shebang "${S}"/run.py
+ insinto /usr/share/"${PN}"
+ doins -r cli FileManagement gui languages locale modules run.py
+ fperms 755 /usr/share/"${PN}"/run.py
+ dosym /usr/share/"${PN}"/run.py /usr/bin/"${PN}"
+ doman subdownloader.1
+ dodoc README ChangeLog
+ doicon gui/images/subdownloader.png
+ domenu subdownloader.desktop
+}