aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/coreboot-utils/files/coreboot-utils-4.14-fix-install-path.patch')
-rw-r--r--sys-apps/coreboot-utils/files/coreboot-utils-4.14-fix-install-path.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-apps/coreboot-utils/files/coreboot-utils-4.14-fix-install-path.patch b/sys-apps/coreboot-utils/files/coreboot-utils-4.14-fix-install-path.patch
new file mode 100644
index 0000000..87a9900
--- /dev/null
+++ b/sys-apps/coreboot-utils/files/coreboot-utils-4.14-fix-install-path.patch
@@ -0,0 +1,39 @@
+diff --git a/util/cbfstool/Makefile b/util/cbfstool/Makefile
+index 7ef46a72..2b61a5de 100644
+--- a/util/cbfstool/Makefile
++++ b/util/cbfstool/Makefile
+@@ -4,7 +4,7 @@ objutil ?= $(top)/util
+ CONFIG_FMD_GENPARSER ?= n
+
+ HOSTCC ?= $(CC)
+-PREFIX ?= /usr/local
++PREFIX ?= /usr
+ BINDIR ?= $(PREFIX)/bin
+ INSTALL ?= /usr/bin/env install
+ OBJCOPY ?= objcopy
+diff --git a/coreboot-4.14/util/ifdtool/Makefile b/util/ifdtool/Makefile
+index e8d818c0..9f56cff3 100644
+--- a/util/ifdtool/Makefile
++++ b/util/ifdtool/Makefile
+@@ -6,7 +6,7 @@ PROGRAM = ifdtool
+
+ CC ?= gcc
+ INSTALL = /usr/bin/env install
+-PREFIX = /usr/local
++PREFIX = /usr
+ CFLAGS = -O2 -g -Wall -Wextra -Wmissing-prototypes -Werror
+ CFLAGS += -I../../src/commonlib/include -I../../src/commonlib/bsd/include
+ CFLAGS += -I../cbfstool/flashmap
+diff --git a/util/intelmetool/Makefile b/util/intelmetool/Makefile
+index a97f380d..8b48bcda 100644
+--- a/util/intelmetool/Makefile
++++ b/util/intelmetool/Makefile
+@@ -4,7 +4,7 @@ PROGRAM = intelmetool
+
+ CC ?= gcc
+ INSTALL ?= /usr/bin/env install
+-PREFIX ?= /usr/local
++PREFIX ?= /usr
+ CFLAGS ?= -O0 -g -Wall -Wextra -Wno-unused-parameter -Wno-sign-compare -Wno-unused-function
+ LDFLAGS += -lpci -lz
+