summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/bibletime/bibletime-9999.ebuild')
-rw-r--r--app-text/bibletime/bibletime-9999.ebuild36
1 files changed, 19 insertions, 17 deletions
diff --git a/app-text/bibletime/bibletime-9999.ebuild b/app-text/bibletime/bibletime-9999.ebuild
index 911be51..595a155 100644
--- a/app-text/bibletime/bibletime-9999.ebuild
+++ b/app-text/bibletime/bibletime-9999.ebuild
@@ -1,24 +1,22 @@
# Copyright 1999-2018 Gentoo Authors
-# Copyright 2010-2018 The BibleTime team
+# Copyright 2010-2020 The BibleTime team
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit cmake-utils git-r3
DESCRIPTION="Qt5 Bible study application using the SWORD library."
HOMEPAGE="http://www.bibletime.info/"
EGIT_REPO_URI="https://github.com/bibletime/bibletime.git"
-IUSE="debug"
-
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="handbook handbook_pdf howto howto_pdf"
RDEPEND="
- >=app-text/sword-1.7[curl]
+ >=app-text/sword-1.8.1[curl]
>=dev-cpp/clucene-0.9.16a
- dev-qt/linguist-tools:5
>=dev-qt/qtcore-5.6.0:5
dev-qt/qtwebengine:5[widgets]
dev-qt/qtwebchannel:5
@@ -28,8 +26,17 @@ RDEPEND="
dev-qt/qtscript:5
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
-dev-qt/qtxml:5"
-DEPEND="${RDEPEND} dev-qt/qttest:5"
+ dev-qt/qtxml:5"
+DEPEND="${RDEPEND}
+ dev-qt/qttest:5"
+HTML_DOC_DEPENDS="app-text/docbook-xsl-stylesheets app-text/po4a dev-libs/libxslt"
+PDF_DOC_DEPENDS="${HTML_DOC_DEPENDS} dev-java/fop"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ handbook? ( ${HTML_DOC_DEPENDS} )
+ handbook_pdf? ( ${PDF_DOC_DEPENDS} )
+ howto? ( ${HTML_DOC_DEPENDS} )
+ howto_pdf? ( ${PDF_DOC_DEPENDS} )"
DOCS="ChangeLog README.md"
@@ -39,15 +46,10 @@ pkg_setup() {
src_configure() {
local mycmakeargs=(
+ -DBUILD_HANDBOOK_HTML=$(usex handbook)
+ -DBUILD_HANDBOOK_PDF=$(usex handbook_pdf)
+ -DBUILD_HOWTO_HTML=$(usex howto)
+ -DBUILD_HOWTO_PDF=$(usex howto_pdf)
)
- if use debug; then
- mycmakeargs+=(
- -DCMAKE_BUILD_TYPE=Debug
- )
- else
- mycmakeargs+=(
- -DCMAKE_BUILD_TYPE=Release
- )
- fi
cmake-utils_src_configure
}