summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRussell Harmon <russ@eatnumber1.com>2009-11-30 18:19:35 -0500
committerRussell Harmon <russ@eatnumber1.com>2009-11-30 18:19:35 -0500
commit2b015385f049bdc53382076438779a8ad6de8252 (patch)
tree01e4579605f820e4b5c420faedaaa5e55da90ace /dev-util
parentRemove metadata cache (diff)
downloadeatnumber1-2b015385f049bdc53382076438779a8ad6de8252.tar.gz
eatnumber1-2b015385f049bdc53382076438779a8ad6de8252.tar.bz2
eatnumber1-2b015385f049bdc53382076438779a8ad6de8252.zip
Add alpha idea ebuild
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/idea/.idea-8.0.1.ebuild.swpbin12288 -> 0 bytes
-rw-r--r--dev-util/idea/idea-9.0_alpha10781.ebuild48
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/idea/.idea-8.0.1.ebuild.swp b/dev-util/idea/.idea-8.0.1.ebuild.swp
deleted file mode 100644
index 5da4cdc..0000000
--- a/dev-util/idea/.idea-8.0.1.ebuild.swp
+++ /dev/null
Binary files differ
diff --git a/dev-util/idea/idea-9.0_alpha10781.ebuild b/dev-util/idea/idea-9.0_alpha10781.ebuild
new file mode 100644
index 0000000..851076f
--- /dev/null
+++ b/dev-util/idea/idea-9.0_alpha10781.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+inherit eutils versionator
+
+function version {
+ local my_v=( $(get_version_components) )
+ my_v=( "${my_v[$(get_last_version_component_index)]}" )
+ echo "${my_v[0]/alpha/}"
+}
+
+MY_PV="$(version)"
+DESCRIPTION="An intelligent Java IDE intensely focused on developer productivity."
+HOMEPAGE="http://www.jetbrains.com/idea/index.html"
+SRC_URI="http://download.jetbrains.com/${PN}/${PN}${MY_PV}.tar.gz"
+
+SLOT="0"
+LICENSE="IntelliJ-IDEA"
+KEYWORDS=""
+RESTRICT="primaryuri"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=virtual/jdk-1.6.0"
+
+S="${WORKDIR}"
+
+QA_TEXTRELS="opt/${P}/bin/libjniwrap.so
+ opt/${P}/bin/libjniwrap_sunos.so
+ opt/${P}/bin/libjniwrap_sunos64.so
+ opt/${P}/bin/libyjpagent.so
+ opt/${P}/bin/libbreakgen.so
+ opt/${P}/bin/libjniwrap64.so"
+
+QA_EXECSTACK="opt/${P}/bin/libjniwrap_sunos.so"
+
+src_prepare() {
+ use amd64 && sed -rie 's/^-agentlib:yjpagent(.*)?$//g' "${PN}-${MY_PV}/bin/idea.vmoptions"
+}
+
+src_install() {
+ mkdir "${D}/opt"
+ mv "${PN}-${MY_PV}" "${D}/opt/"
+ make_wrapper idea /opt/${PN}-${MY_PV}/bin/idea.sh
+ make_wrapper inspect /opt/${PN}-${MY_PV}/bin/inspect.sh
+}