summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-server/tpserver-cpp/tpserver-cpp-0.6.2.ebuild')
-rw-r--r--games-server/tpserver-cpp/tpserver-cpp-0.6.2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/games-server/tpserver-cpp/tpserver-cpp-0.6.2.ebuild b/games-server/tpserver-cpp/tpserver-cpp-0.6.2.ebuild
new file mode 100644
index 0000000..3b2c15c
--- /dev/null
+++ b/games-server/tpserver-cpp/tpserver-cpp-0.6.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2008-2012 Funtoo Technologies
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit games
+
+DESCRIPTION="A C++ server for Thousand Parsec games"
+HOMEPAGE="http://www.thousandparsec.net/tp/"
+SRC_URI="
+ mirror://sourceforge/thousandparsec/${P}.tar.gz
+ ${HOMEPAGE}/downloads/${PN}/${P}.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="avahi gnutls mysql +tpadmin"
+
+DEPEND="
+ dev-libs/boost
+ >=dev-scheme/guile-1.6
+ avahi? ( >=net-dns/avahi-0.6.0 )
+ gnutls? ( >=net-libs/gnutls-1.2.10 )
+ mysql? ( >=dev-db/mysql-4.0 )
+"
+RDEPEND="${DEPEND}
+ tpadmin? ( games-server/tpadmin-cpp )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-stdint.patch"
+)
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_configure() {
+ egamesconf \
+ $(use_enable avahi) \
+ $(use_enable gnutls) \
+ $(use_with mysql) \
+ || die "egamesconf failed"
+}
+
+src_install() {
+ games_src_install
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ keepdir /var/{cache,run}/${PN}
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ insopts -m 0640 -o root -g games
+ doins sample.conf "${FILESDIR}"/tpserver.conf
+
+ prepgamesdirs
+ gamesowners /var/{cache,run}/${PN}
+}