summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHoang Minh Thang <hoangminhthang@ktqd.org>2012-02-19 17:16:34 +0700
committerHoang Minh Thang <hoangminhthang@ktqd.org>2012-02-19 17:16:34 +0700
commit15cd23bb9acb18e9f71b772371f4568029f0cf88 (patch)
tree6fe82fa4e7ba901d3b7cc0e8289ca3c2b845ae06
parentdiffimg slideshoq ipe (diff)
downloadgentoo-vn-15cd23bb9acb18e9f71b772371f4568029f0cf88.tar.gz
gentoo-vn-15cd23bb9acb18e9f71b772371f4568029f0cf88.tar.bz2
gentoo-vn-15cd23bb9acb18e9f71b772371f4568029f0cf88.zip
posterazor
-rw-r--r--app-office/slideshoq/Manifest2
-rw-r--r--app-office/slideshoq/slideshoq-9999.ebuild2
-rw-r--r--media-gfx/posterazor/Manifest1
-rw-r--r--media-gfx/posterazor/posterazor-2.0.ebuild35
4 files changed, 38 insertions, 2 deletions
diff --git a/app-office/slideshoq/Manifest b/app-office/slideshoq/Manifest
index 565e8b8..b0ae7c9 100644
--- a/app-office/slideshoq/Manifest
+++ b/app-office/slideshoq/Manifest
@@ -1 +1 @@
-EBUILD slideshoq-9999.ebuild 760 RMD160 97c2cb5dd50688e4ce6306a2dee016c263650d80 SHA1 e31d0f6aafd2c11a8320daf4daf90d7f5a6fa874 SHA256 cc471ac6fc603757cb50b9f57ddae67cc77a60e9794aeb033ab2c8b70c343b21
+EBUILD slideshoq-9999.ebuild 762 RMD160 f6d3e28e46b2460060458fcb94c72b02c3a75af7 SHA1 27ec03d7cc6f272386bc1aec5abee32c12a1f75f SHA256 af3ea7665bec4b0f2a2e0cf23e56adf0f13615aa235ce9abc46643f3d0575272
diff --git a/app-office/slideshoq/slideshoq-9999.ebuild b/app-office/slideshoq/slideshoq-9999.ebuild
index efa4453..b84c07b 100644
--- a/app-office/slideshoq/slideshoq-9999.ebuild
+++ b/app-office/slideshoq/slideshoq-9999.ebuild
@@ -8,7 +8,7 @@ KEYWORDS="amd64 x86"
DESCRIPTION="SlideShoQ is a PDF presentation software that supports two-screen presentations: One screen shows the current slide fullscreen, i.e. what you want to show on the projector for the audience, the second screen is your computer, which shows the current, next and previous slides, current time and other useful information."
IUSE=""
-inherit git
+inherit git-2
EGIT_REPO_URI="git://gitorious.org/slideshoq/slideshoq.git"
PATCHES=""
diff --git a/media-gfx/posterazor/Manifest b/media-gfx/posterazor/Manifest
new file mode 100644
index 0000000..e882d68
--- /dev/null
+++ b/media-gfx/posterazor/Manifest
@@ -0,0 +1 @@
+EBUILD posterazor-2.0.ebuild 682 RMD160 5993463bb097f233d0c0724aa767c4ec3e894043 SHA1 6d69d3f2325c1cd5e28d80da0d31bfc176191385 SHA256 c0252b5687c29c8748f6218c8098d031a3a368a786b7b625b5e88ad1bb1c35d8
diff --git a/media-gfx/posterazor/posterazor-2.0.ebuild b/media-gfx/posterazor/posterazor-2.0.ebuild
new file mode 100644
index 0000000..b9bd53b
--- /dev/null
+++ b/media-gfx/posterazor/posterazor-2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit git-2
+
+
+EAPI=3
+
+
+DESCRIPTION="PosteRazor cuts raster images into multipage PDF documents."
+HOMEPAGE="http://posterazor.sourceforge.net/"
+LICENSE="GPL-2"
+SLOT="0"
+EGIT_REPO_URI="git://github.com/aportale/posterazor.git"
+SRC_URI=""
+S=${WORKDIR}/${PN}
+
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="media-libs/freeimage
+x11-libs/qt-gui"
+DEPEND="${RDEPEND}"
+src_compile() {
+ cd src
+ qmake -o Makefile posterazor.pro
+ make
+}
+src_install() {
+ mv ${S}/src/PosteRazor ${S}/src/posterazor
+ exeinto /usr/bin
+ doexe ${S}/src/posterazor
+ dodoc ${S}/CHANGES ${S}/LICENSE ${S}/README
+
+}