aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libev/libev-4.15-r1.ebuild')
-rw-r--r--dev-libs/libev/libev-4.15-r1.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-libs/libev/libev-4.15-r1.ebuild b/dev-libs/libev/libev-4.15-r1.ebuild
deleted file mode 100644
index 1e08e29..0000000
--- a/dev-libs/libev/libev-4.15-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-inherit autotools-multilib eutils-multilib multilib
-
-DESCRIPTION="A high-performance event loop/event model with lots of feature"
-HOMEPAGE="http://software.schmorp.de/pkg/libev.html"
-SRC_URI="http://dist.schmorp.de/libev/${P}.tar.gz
- http://dist.schmorp.de/libev/Attic/${P}.tar.gz"
-
-LICENSE="|| ( BSD GPL-2 )"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="elibc_glibc static-libs"
-
-# Bug #283558
-DEPEND="elibc_glibc? ( >=sys-libs/glibc-2.9_p20081201 )"
-RDEPEND="${DEPEND}"
-
-DOCS=( Changes README )
-
-src_prepare() {
- sed -i -e "/^include_HEADERS/s/ event.h//" Makefile.am || die
-
- # bug #411847
- epatch "${FILESDIR}/${PN}-pc.patch"
- AUTOTOOLS_AUTORECONF=yes
- autotools-multilib_src_prepare
-}
-
-src_configure() {
- autotools-multilib_src_configure \
- --disable-maintainer-mode \
- $(use_enable static-libs static)
-}
-
-src_install() {
- use static-libs || AUTOTOOLS_PRUNE_LIBTOOL_FILES=modules
- autotools-multilib_src_install
-}
-
-pkg_preinst() {
- multilib_preserve_old_lib /usr/@GET_LIBDIR@/libev.so.3.0.0
-}
-
-pkg_postinst() {
- multilib_preserve_old_lib_notify /usr/@GET_LIBDIR@/libev.so.3.0.0
-}