summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2011-06-16 16:29:14 +0200
committerMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2011-06-16 16:29:14 +0200
commit56b7c7853e2699b293d2c7d5836e586d0e38181e (patch)
treee8ea386ec3c88cd059fb3e0ed8d937b00d82efd3 /sys-apps
parentold paludis clients are old (diff)
downloadkeruspe-56b7c7853e2699b293d2c7d5836e586d0e38181e.tar.gz
keruspe-56b7c7853e2699b293d2c7d5836e586d0e38181e.tar.bz2
keruspe-56b7c7853e2699b293d2c7d5836e586d0e38181e.zip
update paludis patches
Signed-off-by: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/paludis/Manifest4
-rw-r--r--sys-apps/paludis/files/0001-paludis-sort-world.patch24
-rw-r--r--sys-apps/paludis/files/0002-cave-resolve-ask.patch16
3 files changed, 22 insertions, 22 deletions
diff --git a/sys-apps/paludis/Manifest b/sys-apps/paludis/Manifest
index 60fe5023..502f3c49 100644
--- a/sys-apps/paludis/Manifest
+++ b/sys-apps/paludis/Manifest
@@ -1,3 +1,3 @@
-AUX 0001-paludis-sort-world.patch 6310 RMD160 357a75bb564fbc9cc1393b6f18d5b10c8f0d76b1 SHA1 d97692020706a011096a15bc80313f57f4408529 SHA256 04f2586336bf5923cb63e51283b93f731722dcb28f31d5d5e39bb944bda7b877
-AUX 0002-cave-resolve-ask.patch 8354 RMD160 95e8ecbaa7de594167d7d090b3c704e754cd206c SHA1 70a8d11519c082555e42dc4b6537d28fcd63e4de SHA256 9460e59b21a24ce9483aabdfd1ba01c32383f0a527c7b0462219fab5d126abd7
+AUX 0001-paludis-sort-world.patch 6311 RMD160 15a2b86033389e11040202f339781aa8e3b3c5b6 SHA1 8351a9eed740d5103121c83a13cb930396eb42cf SHA256 98aa98be577781bb2d3fb0d6406b7515b72f01f4ddabb0e56bc02a83ffa2eba8
+AUX 0002-cave-resolve-ask.patch 8355 RMD160 f6c62903d7fc834ad333b2cea28f146f28233b66 SHA1 7a90fdabec67c9f49475c9c57a49bed4b3275caa SHA256 a604a3232f8b1450d2821c8a07d9cd03a5eacc01c94f333535ba3848b1996e14
EBUILD paludis-9999.ebuild 3923 RMD160 0a2a394dcc630f809639f9ad93bd06bc0425013b SHA1 2d470cac95af12dbad498f2296b132164350d6d4 SHA256 aa37c3d6c9a6e3f73cb4fef918cccda7fab8a21d18e90e49c1320fbd65993473
diff --git a/sys-apps/paludis/files/0001-paludis-sort-world.patch b/sys-apps/paludis/files/0001-paludis-sort-world.patch
index 2b93127c..ec446f30 100644
--- a/sys-apps/paludis/files/0001-paludis-sort-world.patch
+++ b/sys-apps/paludis/files/0001-paludis-sort-world.patch
@@ -1,4 +1,4 @@
-From fb0c49bb5fe80cb6ccf3a4e2dd07f0c9580718b0 Mon Sep 17 00:00:00 2001
+From 56dcc8a921e96085afd9154226fd5ba7ab147786 Mon Sep 17 00:00:00 2001
From: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
Date: Mon, 26 Jul 2010 18:17:27 +0200
Subject: [PATCH 1/2] paludis sort world
@@ -63,10 +63,10 @@ index f81a62b..0d8916c 100755
END
diff --git a/paludis/set_file.cc b/paludis/set_file.cc
-index bc62eb6..e6fbe90 100644
+index 646ccf4..f786c5d 100644
--- a/paludis/set_file.cc
+++ b/paludis/set_file.cc
-@@ -61,12 +61,15 @@ namespace
+@@ -60,12 +60,15 @@ namespace
protected:
SetFileHandler();
@@ -82,7 +82,7 @@ index bc62eb6..e6fbe90 100644
virtual void rewrite() const = 0;
};
-@@ -88,6 +91,7 @@ namespace
+@@ -87,6 +90,7 @@ namespace
virtual std::shared_ptr<SetSpecTree> contents() const;
virtual bool add(const std::string &);
virtual bool remove(const std::string &);
@@ -90,7 +90,7 @@ index bc62eb6..e6fbe90 100644
virtual void rewrite() const;
};
-@@ -104,6 +108,7 @@ namespace
+@@ -103,6 +107,7 @@ namespace
virtual std::shared_ptr<SetSpecTree> contents() const;
virtual bool add(const std::string &) PALUDIS_ATTRIBUTE((noreturn));
virtual bool remove(const std::string &) PALUDIS_ATTRIBUTE((noreturn));
@@ -98,7 +98,7 @@ index bc62eb6..e6fbe90 100644
virtual void rewrite() const PALUDIS_ATTRIBUTE((noreturn));
};
-@@ -125,6 +130,7 @@ namespace
+@@ -124,6 +129,7 @@ namespace
virtual std::shared_ptr<SetSpecTree> contents() const;
virtual bool add(const std::string &);
virtual bool remove(const std::string &);
@@ -106,7 +106,7 @@ index bc62eb6..e6fbe90 100644
virtual void rewrite() const;
};
-@@ -304,6 +310,22 @@ SetFileHandler::~SetFileHandler()
+@@ -303,6 +309,22 @@ SetFileHandler::~SetFileHandler()
{
}
@@ -129,7 +129,7 @@ index bc62eb6..e6fbe90 100644
SimpleHandler::SimpleHandler(const SetFileParams & p) :
_p(p)
{
-@@ -409,6 +431,17 @@ SimpleHandler::remove(const std::string & p)
+@@ -408,6 +430,17 @@ SimpleHandler::remove(const std::string & p)
}
void
@@ -147,7 +147,7 @@ index bc62eb6..e6fbe90 100644
SimpleHandler::rewrite() const
{
Lock l(_mutex);
-@@ -502,6 +535,17 @@ PaludisConfHandler::remove(const std::string & p)
+@@ -501,6 +534,17 @@ PaludisConfHandler::remove(const std::string & p)
}
void
@@ -165,7 +165,7 @@ index bc62eb6..e6fbe90 100644
PaludisConfHandler::rewrite() const
{
Context context("When rewriting paludis conf set file '" + stringify(_p.file_name()) + "':");
-@@ -574,6 +618,12 @@ PaludisBashHandler::remove(const std::string & p)
+@@ -572,6 +616,12 @@ PaludisBashHandler::remove(const std::string & p)
}
void
@@ -178,7 +178,7 @@ index bc62eb6..e6fbe90 100644
PaludisBashHandler::rewrite() const
{
throw SetFileError(_p.file_name(), "Cannot modify bash script '" + stringify(_p.file_name()) + "'");
-@@ -611,6 +661,12 @@ SetFile::contents() const
+@@ -609,6 +659,12 @@ SetFile::contents() const
}
void
@@ -208,5 +208,5 @@ index e3a853c..019ccbb 100644
*/
void rewrite() const;
--
-1.7.4.1.294.gaf4c6.dirty
+1.7.6.rc1.1.g2c162b.dirty
diff --git a/sys-apps/paludis/files/0002-cave-resolve-ask.patch b/sys-apps/paludis/files/0002-cave-resolve-ask.patch
index 1189fc12..15337393 100644
--- a/sys-apps/paludis/files/0002-cave-resolve-ask.patch
+++ b/sys-apps/paludis/files/0002-cave-resolve-ask.patch
@@ -1,4 +1,4 @@
-From 7ce50ff8fba89792d7f1f647598db704a5d5193a Mon Sep 17 00:00:00 2001
+From 0bd45d930737092c9c754386666d800fbefc60ad Mon Sep 17 00:00:00 2001
From: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
Date: Mon, 26 Jul 2010 18:38:14 +0200
Subject: [PATCH 2/2] cave resolve ask
@@ -41,7 +41,7 @@ index a43287f..ef6ba64 100644
<p>Non-Problem: Paludis doesn't restore the xterm title on exit.</p>
diff --git a/src/clients/cave/cmd_execute_resolution.cc b/src/clients/cave/cmd_execute_resolution.cc
-index e1bdc14..f2a4dbc 100644
+index b9b71c1..260bd0d 100644
--- a/src/clients/cave/cmd_execute_resolution.cc
+++ b/src/clients/cave/cmd_execute_resolution.cc
@@ -104,7 +104,8 @@ namespace
@@ -118,10 +118,10 @@ index e0a7f2a..9985df5 100644
std::string app_name() const
diff --git a/src/clients/cave/resolve_cmdline.cc b/src/clients/cave/resolve_cmdline.cc
-index 2a107d7..b84f73d 100644
+index 90252b0..6b1ad27 100644
--- a/src/clients/cave/resolve_cmdline.cc
+++ b/src/clients/cave/resolve_cmdline.cc
-@@ -47,6 +47,7 @@ ResolveCommandLineResolutionOptions::ResolveCommandLineResolutionOptions(args::A
+@@ -46,6 +46,7 @@ ResolveCommandLineResolutionOptions::ResolveCommandLineResolutionOptions(args::A
ArgsSection(h, "Resolution Options"),
g_execution_options(this, "Execution Options", "Control execution."),
a_execute(&g_execution_options, "execute", 'x', "Execute the suggested actions", true),
@@ -130,7 +130,7 @@ index 2a107d7..b84f73d 100644
g_convenience_options(this, "Convenience Options", "Broad behaviour options. These options are simply "
"a convenient way of selecting common groups of other options; see individual option descriptions "
diff --git a/src/clients/cave/resolve_cmdline.hh b/src/clients/cave/resolve_cmdline.hh
-index 8ee7b02..3483358 100644
+index 8bdd0b4..589230c 100644
--- a/src/clients/cave/resolve_cmdline.hh
+++ b/src/clients/cave/resolve_cmdline.hh
@@ -36,6 +36,7 @@ namespace paludis
@@ -142,10 +142,10 @@ index 8ee7b02..3483358 100644
args::ArgsGroup g_convenience_options;
args::SwitchArg a_lazy;
diff --git a/src/clients/cave/resolve_common.cc b/src/clients/cave/resolve_common.cc
-index cd8d643..83c144f 100644
+index b095dfc..d1727a2 100644
--- a/src/clients/cave/resolve_common.cc
+++ b/src/clients/cave/resolve_common.cc
-@@ -428,6 +428,8 @@ namespace
+@@ -427,6 +427,8 @@ namespace
if (pretend_only || ! resolution_options.a_execute.specified())
args->push_back("--pretend");
@@ -167,5 +167,5 @@ index 7067fa8..cd774bb 100644
'(--lazy -z --complete -c --everything -e --no-lazy --no-complete --no-everything)'{--complete,-c,--no-complete}'[Do all optional work]' \
'(--lazy -z --complete -c --everything -e --no-lazy --no-complete --no-everything)'{--everything,-e,--no-everything}'[Do all optional work, and also reinstall]' \
--
-1.7.4.1.294.gaf4c6.dirty
+1.7.6.rc1.1.g2c162b.dirty