summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2011-05-26 14:38:26 +0200
committerMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2011-05-26 14:38:26 +0200
commit7836ab426770ac35db9b6c09feebde2e6326d21f (patch)
tree3b414cabb3c4c259a85987f577c3974e321d6a5a /sys-apps
parentgnome-shell[recorder] (diff)
downloadkeruspe-7836ab426770ac35db9b6c09feebde2e6326d21f.tar.gz
keruspe-7836ab426770ac35db9b6c09feebde2e6326d21f.tar.bz2
keruspe-7836ab426770ac35db9b6c09feebde2e6326d21f.zip
update systemd from ::systemd
Signed-off-by: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd/Manifest2
-rw-r--r--sys-apps/systemd/systemd-9999-r1.ebuild131
2 files changed, 89 insertions, 44 deletions
diff --git a/sys-apps/systemd/Manifest b/sys-apps/systemd/Manifest
index 2ef28e61..dc395e16 100644
--- a/sys-apps/systemd/Manifest
+++ b/sys-apps/systemd/Manifest
@@ -1 +1 @@
-EBUILD systemd-9999-r1.ebuild 3661 RMD160 300a3865864d29da68c901b5e470df668f6886bf SHA1 5e33499c42e140fb49bf018298768c032d6fa7cb SHA256 c42be42b9cf144f06fa439dce9e2d0cfe203961a5e73e9032e22adf7bf196b48
+EBUILD systemd-9999-r1.ebuild 4878 RMD160 ae5f1d463502cbf655ec065248098efae197d18f SHA1 31227db9bd7ce1785e17a49f3fa08398d12cae77 SHA256 1daeab60709d0233b9c725327a73810e2ff0c9d661ee143a1897184386078afd
diff --git a/sys-apps/systemd/systemd-9999-r1.ebuild b/sys-apps/systemd/systemd-9999-r1.ebuild
index 457ea2eb..d4c99fc4 100644
--- a/sys-apps/systemd/systemd-9999-r1.ebuild
+++ b/sys-apps/systemd/systemd-9999-r1.ebuild
@@ -13,70 +13,89 @@ EGIT_REPO_URI="git://anongit.freedesktop.org/systemd"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="audit cryptsetup gtk +pam python selinux symlinks sysv +tcpwrap"
+IUSE="audit cryptsetup gtk +pam python plymouth selinux symlinks +tcpwrap"
-RDEPEND="
- >=sys-apps/dbus-1.4.0
+COMMON_DEPEND=">=sys-apps/dbus-1.4.8-r1
sys-libs/libcap
>=sys-fs/udev-168
audit? ( sys-process/audit )
cryptsetup? ( sys-fs/cryptsetup )
- gtk? ( >=x11-libs/gtk+-2.20:2
- x11-libs/libnotify
- dev-libs/dbus-glib )
- tcpwrap? ( sys-apps/tcp-wrappers )
+ gtk? (
+ dev-libs/dbus-glib
+ >=dev-libs/glib-2.26
+ x11-libs/gtk+:2
+ >=x11-libs/libnotify-0.7 )
pam? ( virtual/pam )
python? ( dev-python/dbus-python
dev-python/pycairo )
symlinks? ( !!sys-apps/sysvinit )
selinux? ( sys-libs/libselinux )
+ tcpwrap? ( sys-apps/tcp-wrappers )
>=sys-apps/util-linux-2.19
+ plymouth? ( >=sys-boot/plymouth-0.8.4 )"
+
+RDEPEND="${COMMON_DEPEND}
sys-apps/systemd-units
>=app-admin/syslog-ng-3
sys-apps/lsb-release
sys-apps/baselayout-systemd"
-DEPEND="${RDEPEND}
- gtk? ( dev-lang/vala:0.12 )
- >=sys-kernel/linux-headers-2.6.32"
+VALASLOT="0.12"
+MINKV="2.6.38"
+DEPEND="${COMMON_DEPEND}
+ gtk? ( dev-lang/vala:${VALASLOT} )
+ >=sys-kernel/linux-headers-${MINKV}"
+
+check_no_uevent_hotplug_helper() {
+ local path
+ if linux_config_exists; then
+ path="$(linux_chkconfig_string UEVENT_HELPER_PATH)"
+ path="${path#\"}"
+ path="${path%\"}"
+ path="${path#\'}"
+ path="${path%\'}"
+ if test "${path}" != ""; then
+ qewarn "The kernel should be configured with"
+ qewarn "CONFIG_UEVENT_HELPER_PATH=\"\". Also, be sure to check"
+ qewarn "that /proc/sys/kernel/hotplug is empty."
+ fi
+ fi
+}
-CONFIG_CHECK="AUTOFS4_FS CGROUPS DEVTMPFS ~FANOTIFY ~IPV6"
+pkg_pretend() {
+ local CONFIG_CHECK="AUTOFS4_FS CGROUPS DEVTMPFS ~FANOTIFY ~IPV6"
+ linux-info_pkg_setup
+ check_no_uevent_hotplug_helper
+ kernel_is -ge ${MINKV//./ } || die "Kernel version at least ${MINKV} required"
+}
pkg_setup() {
enewgroup lock # used by var-lock.mount
enewgroup tty 5 # used by mount-setup for /dev/pts
}
-pkg_pretend() {
- check_extra_config
-}
-
src_prepare() {
+ epatch_user
eautoreconf
}
src_configure() {
- local myconf=
-
- if use sysv; then
- myconf="${myconf} --with-sysvinit-path=/etc/init.d --with-sysvrcd-path=/etc"
- else
- myconf="${myconf} --with-sysvinit-path= --with-sysvrcd-path="
- fi
-
- if use gtk; then
- export VALAC="$(type -p valac-0.12)"
- fi
-
- econf --with-distro=gentoo \
- --with-rootdir= \
- --localstatedir=/var \
- $(use_enable audit) \
- $(use_enable cryptsetup libcryptsetup) \
- $(use_enable gtk) \
- $(use_enable pam) \
- $(use_enable tcpwrap) \
- $(use_enable selinux) \
- ${myconf}
+ local myconf="
+ --with-distro=gentoo
+ --with-rootdir=
+ --localstatedir=/var
+ $(use_enable audit)
+ $(use_enable cryptsetup libcryptsetup)
+ $(use_enable gtk)
+ $(use_enable pam)
+ $(use_enable selinux)
+ $(use_enable tcpwrap)
+ "
+
+ use gtk && export VALAC="$(type -p valac-${VALASLOT})"
+
+ use plymouth && export have_plymouth=1
+
+ econf ${myconf}
}
rename_mans() {
@@ -95,10 +114,10 @@ do_symlinks() {
}
src_install() {
- emake DESTDIR=${ED} install || die "emake install failed"
+ emake DESTDIR=${ED} install
- dodoc "${ED}/usr/share/doc/systemd"/* && \
- rm -r "${ED}/usr/share/doc/systemd/"
+ dodoc "${ED}"/usr/share/doc/systemd/*
+ rm -rf "${ED}"/usr/share/doc/systemd
keepdir /run
if use symlinks; then
@@ -114,27 +133,50 @@ check_mtab_is_symlink() {
ewarn "${ROOT}etc/mtab must be a symlink to ${ROOT}proc/self/mounts!"
ewarn "To correct that, execute"
ewarn " $ ln -sf '${ROOT}proc/self/mounts' '${ROOT}etc/mtab'"
+ elog
fi
}
systemd_machine_id_setup() {
einfo "Setting up /etc/machine-id..."
- "${ROOT}"bin/systemd-machine-id-setup
- if test $? != 0; then
+ if ! "${ROOT}"bin/systemd-machine-id-setup; then
ewarn "Setting up /etc/machine-id failed, to fix it please see"
ewarn " http://lists.freedesktop.org/archives/dbus/2011-March/014187.html"
+ elog
elif test ! -L "${ROOT}"var/lib/dbus/machine-id; then
# This should be fixed in the dbus ebuild, but we warn about it here.
ewarn "${ROOT}var/lib/dbus/machine-id ideally should be a symlink to"
ewarn "${ROOT}etc/machine-id to make it clear that they have the same"
ewarn "content."
+ elog
+ else
+ einfo
+ fi
+}
+
+check_var_run_is_symlink() {
+ if test ! -L "${ROOT}"var/run; then
+ elog "${ROOT}var/run should be a symlink to ${ROOT}run. This is not"
+ elog "trivial to change, and there is no hurry as it is currently"
+ elog "bind-mounted at boot-time. You may be able to create the"
+ elog "symlink by lazily unmounting ${ROOT}var/run first."
+ elog
+ fi
+}
+
+check_var_lock_is_symlink() {
+ if test ! -L "${ROOT}"var/lock; then
+ elog "${ROOT}var/lock should be a symlink to ${ROOT}run/lock, see"
+ elog " https://lwn.net/Articles/436012/"
+ elog
fi
}
pkg_postinst() {
check_mtab_is_symlink
-
systemd_machine_id_setup
+ check_var_run_is_symlink
+ check_var_lock_is_symlink
# Inform user about extra configuration
elog "You may need to perform some additional configuration for some"
@@ -142,4 +184,7 @@ pkg_postinst() {
elog "handling tmpfiles:"
elog " $ man modules-load.d"
elog " $ man tmpfiles.d"
+ elog
+
+ ewarn "This is a work-in-progress ebuild. You may brick your system. Have fun!"
}