summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2011-11-08 11:53:55 +0100
committerMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2011-11-08 12:00:14 +0100
commit8d550006a3f5196ca7acf487942ddc19fe3757c8 (patch)
tree9bfc0ec6aacf0d9decda0cc2cc18ef1433876494 /sys-apps
parentmissing patch (diff)
downloadkeruspe-8d550006a3f5196ca7acf487942ddc19fe3757c8.tar.gz
keruspe-8d550006a3f5196ca7acf487942ddc19fe3757c8.tar.bz2
keruspe-8d550006a3f5196ca7acf487942ddc19fe3757c8.zip
update moar stuff
Signed-off-by: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/baselayout/Manifest2
-rw-r--r--sys-apps/baselayout/baselayout-2.1-r1.ebuild20
2 files changed, 14 insertions, 8 deletions
diff --git a/sys-apps/baselayout/Manifest b/sys-apps/baselayout/Manifest
index 756f0f66..9ddf43ae 100644
--- a/sys-apps/baselayout/Manifest
+++ b/sys-apps/baselayout/Manifest
@@ -1,2 +1,2 @@
DIST baselayout-2.1.tar.bz2 40398 RMD160 bba874c5d3290848236703125c130107c1244f55 SHA1 84783a773ec050700b3b0ce4c7645ae878f7f7fb SHA256 2ac6f2156513a2820a0eeeecc2cf7e7c0b5e0c750b324f1e21912d5f3cda4956
-EBUILD baselayout-2.1-r1.ebuild 7327 RMD160 cda5782340eddfd9af1d0552eb604b00d2a43218 SHA1 b3b40efb60463e5937797358019af9e07e2c996f SHA256 1cd88bc52096eabf2740972017157772cbc7a6ce25733d1385241e471a94a3a4
+EBUILD baselayout-2.1-r1.ebuild 7586 RMD160 6313622f636cec9a22d7447a9771a48885a6ce06 SHA1 2ab68da0981f80362a5d5ac76184d2700b88c5b8 SHA256 4258dacd78aed797d67bac51091c8a6b4296746a8a31c8fe20ca6874c80aaeb7
diff --git a/sys-apps/baselayout/baselayout-2.1-r1.ebuild b/sys-apps/baselayout/baselayout-2.1-r1.ebuild
index ee0d6748..d4c89714 100644
--- a/sys-apps/baselayout/baselayout-2.1-r1.ebuild
+++ b/sys-apps/baselayout/baselayout-2.1-r1.ebuild
@@ -11,7 +11,7 @@ SRC_URI="mirror://gentoo/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
IUSE="build +openrc"
PDEPEND="openrc? ( sys-apps/openrc )
@@ -37,6 +37,8 @@ multilib_layout() {
local libdir libdirs=$(get_all_libdirs) def_libdir=$(get_abi_LIBDIR $DEFAULT_ABI)
: ${libdirs:=lib} # it isn't that we don't trust multilib.eclass...
+ [ -z "${def_libdir}" ] && die "your DEFAULT_ABI=$DEFAULT_ABI appears to be invalid"
+
# figure out which paths should be symlinks and which should be directories
local dirs syms exp d
for libdir in ${libdirs} ; do
@@ -101,13 +103,17 @@ multilib_layout() {
# make sure the old "lib" ABI location does not exist; we
# only symlinked the lib dir on systems where we moved it
# to "lib32" ...
- if [ -d "${prefix}lib32" ] ; then
- rm -f "${prefix}lib32"/.keep
- if ! rmdir "${prefix}lib32" 2>/dev/null ; then
- ewarn "You need to merge ${prefix}lib32 into ${prefix}lib"
- die "non-empty dir found where there should be none: ${prefix}lib32"
+ case ${CHOST} in
+ i?86*|x86_64*|powerpc*|sparc*|s390*)
+ if [ -d "${prefix}lib32" ] ; then
+ rm -f "${prefix}lib32"/.keep
+ if ! rmdir "${prefix}lib32" 2>/dev/null ; then
+ ewarn "You need to merge ${prefix}lib32 into ${prefix}lib"
+ die "non-empty dir found where there should be none: ${prefix}lib32"
+ fi
fi
- fi
+ ;;
+ esac
else
# nothing exists, so just set it up sanely
ewarn "Initializing ${prefix}lib as a dir"