summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPalmer Dabbelt <palmer@dabbelt.com>2019-05-10 18:29:55 -0700
committerPalmer Dabbelt <palmer@dabbelt.com>2019-05-10 18:29:55 -0700
commit21735b991852c9d5ba218cb61f3405bf464f0325 (patch)
tree72c593fde9367025bbf74089efcb0036df298b84
parentdev-libs/log4c: New ebuild (diff)
downloadpalmer-21735b991852c9d5ba218cb61f3405bf464f0325.tar.gz
palmer-21735b991852c9d5ba218cb61f3405bf464f0325.tar.bz2
palmer-21735b991852c9d5ba218cb61f3405bf464f0325.zip
dev-python/soundcloud-python: New ebuild
Signed-off-by: Palmer Dabbelt <palmer@dabbelt.com>
-rw-r--r--dev-python/soundcloud-python/Manifest1
-rw-r--r--dev-python/soundcloud-python/soundcloud-python-0.5.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/soundcloud-python/Manifest b/dev-python/soundcloud-python/Manifest
new file mode 100644
index 0000000..bde570e
--- /dev/null
+++ b/dev-python/soundcloud-python/Manifest
@@ -0,0 +1 @@
+DIST soundcloud-python-0.5.0.tar.gz 10223 BLAKE2B 2d0111403a232814b04f919a0d23b966641c8cb71b031766dc6eb438f3c3ca04d99b324fa9ae12aa60c65a47c4654e379b74177a0802173faf326246d97d33c1 SHA512 a98fe88bca755c7a4351798cfcca2146a6c37bc760b3a22012e0cb2cb3bc29402fcfea72ddf3344c44e3db69024818478faa6174e854ae177f7bb8acb74569e4
diff --git a/dev-python/soundcloud-python/soundcloud-python-0.5.0.ebuild b/dev-python/soundcloud-python/soundcloud-python-0.5.0.ebuild
new file mode 100644
index 0000000..82a61e8
--- /dev/null
+++ b/dev-python/soundcloud-python/soundcloud-python-0.5.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A friendly wrapper around the Soundcloud API"
+HOMEPAGE="https://github.com/soundcloud/soundcloud-python"
+SRC_URI="https://github.com/${PN/-*}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPEND}"
+RDEPEND="${DEPEND}
+ >=dev-python/fudge-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-2.0[${PYTHON_USEDEP}]"