summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/amqplib/amqplib-0.6.1.ebuild')
-rw-r--r--dev-python/amqplib/amqplib-0.6.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/amqplib/amqplib-0.6.1.ebuild b/dev-python/amqplib/amqplib-0.6.1.ebuild
new file mode 100644
index 0000000..1c84ccb
--- /dev/null
+++ b/dev-python/amqplib/amqplib-0.6.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.4:2.6"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Python client for the Advanced Message Queuing Procotol (AMQP)"
+HOMEPAGE="http://code.google.com/p/py-amqplib/"
+SRC_URI="http://py-amqplib.googlecode.com/files/${P}.tgz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="examples extras test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" pytest -v
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ dodoc docs/*
+ if use examples; then
+ docinto examples
+ dodoc demo/* || die "dodoc failed"
+ fi
+ if use extras; then
+ insinto /usr/share/${PF}
+ doins -r extras || die "doins failed"
+ fi
+
+}