summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Labedan <plabedan@gmail.com>2015-01-25 18:41:04 +0100
committerPaul Labedan <plabedan@gmail.com>2015-01-25 18:46:38 +0100
commit70aadafd59792274c980cb626cbdbbcae863d557 (patch)
treeb071c11bb1c7958566315ba1d0d19f52f53fd46c /media-libs
parentadd mesa 10.4.3 (diff)
downloadplab-70aadafd59792274c980cb626cbdbbcae863d557.tar.gz
plab-70aadafd59792274c980cb626cbdbbcae863d557.tar.bz2
plab-70aadafd59792274c980cb626cbdbbcae863d557.zip
add clutter 1.21.4
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/clutter/Manifest2
-rw-r--r--media-libs/clutter/clutter-1.21.4.ebuild110
2 files changed, 112 insertions, 0 deletions
diff --git a/media-libs/clutter/Manifest b/media-libs/clutter/Manifest
new file mode 100644
index 0000000..6047273
--- /dev/null
+++ b/media-libs/clutter/Manifest
@@ -0,0 +1,2 @@
+DIST clutter-1.21.4.tar.xz 5262608 SHA256 c96ffd45ef3951a503e04d215b4f9eac9afd27238d8a3da9e854d3e2a9c7c3c4 SHA512 b0d1417670d3aef5acf65c3e0825eea43cd74d6439c84875878fe6d96e8c1343e11f67a72ae4236726f5a2347b05c254361d1599ac04f926106878b029a18965 WHIRLPOOL 9797e7af0a5527284098d8d14a94e95bcec51081c74593b29f472639b804619df1bda09cea57211037b17f34b2e23e5f900e1755a2691dbf9bf4313df0f469c9
+EBUILD clutter-1.21.4.ebuild 3138 SHA256 633475e4800937282a6472f8ff5902aa42cd895c3bc10d2a85454e22d0040eb9 SHA512 518c390427019bff207b9791e246236ce6a26fdb99d4fd0591ca4d82dc3bdb4dfbd19abd393a25d95a20559ac2eb55aaedc250c1467db4585b12264dd783fce3 WHIRLPOOL d2a7094dd15dd0c1c2295c0d1c69d8919f8601b8fe5e60d5fc3751c8990a4f7107cbfc3570d429f636149c3d5b9fd49260293f26feccf70889757c2305180ea4
diff --git a/media-libs/clutter/clutter-1.21.4.ebuild b/media-libs/clutter/clutter-1.21.4.ebuild
new file mode 100644
index 0000000..5762b3c
--- /dev/null
+++ b/media-libs/clutter/clutter-1.21.4.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter/clutter-1.20.0.ebuild,v 1.1 2014/12/23 22:53:28 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 virtualx
+
+HOMEPAGE="https://wiki.gnome.org/Projects/Clutter"
+DESCRIPTION="Clutter is a library for creating graphical user interfaces"
+
+LICENSE="LGPL-2.1+ FDL-1.1+"
+SLOT="1.0"
+IUSE="aqua debug doc egl gtk +introspection test wayland +X"
+REQUIRED_USE="
+ || ( aqua wayland X )
+ wayland? ( egl )
+"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+# NOTE: glx flavour uses libdrm + >=mesa-7.3
+# XXX: uprof needed for profiling
+# >=libX11-1.3.1 needed for X Generic Event support
+# do not depend on tslib, it does not build and is disable by default upstream
+RDEPEND="
+ >=dev-libs/glib-2.37.3:2
+ >=dev-libs/atk-2.5.3[introspection?]
+ >=dev-libs/json-glib-0.12[introspection?]
+ >=media-libs/cogl-1.17.5:1.0=[introspection?,pango,wayland?]
+ >=x11-libs/cairo-1.12:=[aqua?,glib]
+ >=x11-libs/pango-1.30[introspection?]
+
+ virtual/opengl
+ x11-libs/libdrm:=
+
+ egl? (
+ >=dev-libs/libinput-0.4
+ media-libs/cogl[gles2,kms]
+ >=virtual/libgudev-136
+ x11-libs/libxkbcommon
+ )
+ gtk? ( >=x11-libs/gtk+-3.3.18:3[aqua?] )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+ X? (
+ media-libs/fontconfig
+ >=x11-libs/libX11-1.3.1
+ x11-libs/libXext
+ x11-libs/libXdamage
+ x11-proto/inputproto
+ >=x11-libs/libXi-1.3
+ >=x11-libs/libXcomposite-0.4 )
+ wayland? (
+ dev-libs/wayland
+ x11-libs/gdk-pixbuf:2 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.20
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ doc? (
+ >=dev-util/gtk-doc-1.20
+ >=app-text/docbook-sgml-utils-0.6.14[jadetex]
+ dev-libs/libxslt )
+ test? ( x11-libs/gdk-pixbuf )"
+
+# Tests fail with both swrast and llvmpipe
+# They pass under r600g or i965, so the bug is in mesa
+#RESTRICT="test"
+
+src_prepare() {
+ # We only need conformance tests, the rest are useless for us
+ sed -e 's/^\(SUBDIRS =\).*/\1 accessibility conform/g' \
+ -i tests/Makefile.am || die "am tests sed failed"
+ sed -e 's/^\(SUBDIRS =\)[^\]*/\1 accessibility conform/g' \
+ -i tests/Makefile.in || die "in tests sed failed"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # XXX: Conformance test suite (and clutter itself) does not work under Xvfb
+ # (GLX error blabla)
+ # XXX: Profiling, coverage disabled for now
+ # XXX: What about cex100/win32 backends?
+ gnome2_src_configure \
+ --disable-profile \
+ --disable-maintainer-flags \
+ --disable-gcov \
+ --disable-cex100-backend \
+ --disable-win32-backend \
+ --disable-tslib-input \
+ $(use_enable aqua quartz-backend) \
+ $(usex debug --enable-debug=yes --enable-debug=minimum) \
+ $(use_enable doc docs) \
+ $(use_enable egl egl-backend) \
+ $(use_enable egl evdev-input) \
+ $(use_enable gtk gdk-backend) \
+ $(use_enable introspection) \
+ $(use_enable test gdk-pixbuf) \
+ $(use_enable wayland wayland-backend) \
+ $(use_enable wayland wayland-compositor) \
+ $(use_enable X xinput) \
+ $(use_enable X x11-backend)
+}
+
+src_test() {
+ Xemake check -C tests/conform
+}