summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mplayer/Manifest5
-rw-r--r--media-video/mplayer/files/af_equalizer.c.diff75
-rw-r--r--media-video/mplayer/mplayer-9999-r120930.ebuild728
3 files changed, 0 insertions, 808 deletions
diff --git a/media-video/mplayer/Manifest b/media-video/mplayer/Manifest
deleted file mode 100644
index 092a1e7..0000000
--- a/media-video/mplayer/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-AUX af_equalizer.c.diff 2524 SHA256 a34ac06eacbd107b98c63a5f58e579ddae1297c16c72fbc179c9022196215183 SHA512 9d8e3f5febe46b87fc52690a5470a46c8d532481de4594be45dfd8a066e66e077d02d445b98009b055abbd600c0a400178e3c7c8c2f7d9cae84182ddaa5fcb5a WHIRLPOOL 96c9f055d5a85e42155e7b2dea3e55ca407620c88c7c05bea846da9dee6dbf9bfeddf2747f189d51691b9f58c4c2fe8be10dacc81a32bc5d4da6a923d44b97f7
-DIST font-arial-cp1250.tar.bz2 249705 SHA256 423a07e780bb130cd8e4730715545c5d919c248dda595aab7a0a01de3c83fd12 SHA512 4f77ff5ceb8ec6e5d9f8f34d8950a6a6276d1fd5a947772fcbdb6554988b1ea665c12b82f45164f91fb7bd08000cb4afc26fa35beb4c760464160e22b9b8c340 WHIRLPOOL d635f54be65b0ca1047d943b6f6da433cda9fce6ed74fcab993501cf7f6b443eb711e182cd7fff09e553d251b5fd1c60196aa22e8370cba99fa175ed5ecdb47f
-DIST font-arial-iso-8859-1.tar.bz2 234242 SHA256 9730f481764f367c9089d0166fb6ccf9148808ffbbfeca635cf0e6db75765d29 SHA512 a1d03b6f09c48f48b7733f3bc0402ceab239a9abf88b860d852ea9fe69b4da690208a79d6f29d30204f5b37becf10672e8e8c0bfef201846d80ec54df617d029 WHIRLPOOL 8050362b125d3ca98214526cee2fa685e31487d13a6483c765bfc844bdc5e07beeba2c1ba313458096d43a63edd6c5e80b8b388c2792fc0ec7421e4072d8ca25
-DIST font-arial-iso-8859-2.tar.bz2 222208 SHA256 71debfc960007c2f6242dfc91e8b1c005b30a99e129aeb00ab8c03f4371b41c1 SHA512 5671e628303fd816f64a51ad10e2f4dd9c3dc1b34c379a2ecf489b83931db7af668aaa4e00e96a00cacd63ed98daeae6b6a4d5925edfb06fc98d3a923f70257d WHIRLPOOL 08178087b4ea1dfb2250f4673785e31dd876b06af51c51b2bddc172b23e6e33cbc1b2c6b710a317e42dc05486974b26ed0ad3ca50a185567aa77d49bd1e72aee
-EBUILD mplayer-9999-r120930.ebuild 19530 SHA256 14f9028c3426001eebf3da74f2f397ec936b8335d4df996af298c232f5327227 SHA512 ac20b97afdd0da1c3645a84e1db03e3e59e0b4f39b28a37c0b9bb793adc512ba345ff5dd11cefe483298d3adadbea4f77e20852ec39136c6913d7cd7a9eed770 WHIRLPOOL 3513cae81a8b402a4e79370a7ec563375db4b5cef2f580929b7d720d56a75513b2e7718d006f1113b4bb2d20b830e53151e3d429dae8d50c08e62d8ac6be3dde
diff --git a/media-video/mplayer/files/af_equalizer.c.diff b/media-video/mplayer/files/af_equalizer.c.diff
deleted file mode 100644
index 7855891..0000000
--- a/media-video/mplayer/files/af_equalizer.c.diff
+++ /dev/null
@@ -1,75 +0,0 @@
---- libaf/af_equalizer.c.orig 2009-05-13 04:58:57.000000000 +0200
-+++ libaf/af_equalizer.c 2010-03-09 22:03:10.000000000 +0100
-@@ -51,7 +51,7 @@
- 8 8.000 kHz
- 9 16.00 kHz
- */
--#define CF {31.25,62.5,125,250,500,1000,2000,4000,8000,16000}
-+#define CF {23.4375,46.875,93.75,187.5,375,750,1500,3000,6000,12000}
-
- // Maximum and minimum gain for the bands
- #define G_MAX +12.0
-@@ -60,9 +60,9 @@
- // Data for specific instances of this filter
- typedef struct af_equalizer_s
- {
-- float a[KM][L]; // A weights
-- float b[KM][L]; // B weights
-- float wq[AF_NCH][KM][L]; // Circular buffer for W data
-+ double a[KM][L]; // A weights
-+ double b[KM][L]; // B weights
-+ double wq[AF_NCH][KM][L]; // Circular buffer for W data
- float g[AF_NCH][KM]; // Gain factor for each channel and band
- int K; // Number of used eq bands
- int channels; // Number of channels
-@@ -70,9 +70,9 @@
- } af_equalizer_t;
-
- // 2nd order Band-pass Filter design
--static void bp2(float* a, float* b, float fc, float q){
-+static void bp2(double* a, double* b, double fc, double q){
- double th= 2.0 * M_PI * fc;
-- double C = (1.0 - tan(th*q/2.0))/(1.0 + tan(th*q/2.0));
-+ double C = (1.0 - tan(th*q/4.0))/(1.0 + tan(th*q/4.0));
-
- a[0] = (1.0 + C) * cos(th);
- a[1] = -1 * C;
-@@ -89,7 +89,7 @@
- switch(cmd){
- case AF_CONTROL_REINIT:{
- int k =0, i =0;
-- float F[KM] = CF;
-+ double F[KM] = CF;
-
- s->gain_factor=0.0;
-
-@@ -103,7 +103,7 @@
-
- // Calculate number of active filters
- s->K=KM;
-- while(F[s->K-1] > (float)af->data->rate/2.2)
-+ while(F[s->K-1] > (double)af->data->rate/2.2)
- s->K--;
-
- if(s->K != KM)
-@@ -112,7 +112,7 @@
-
- // Generate filter taps
- for(k=0;k<s->K;k++)
-- bp2(s->a[k],s->b[k],F[k]/((float)af->data->rate),Q);
-+ bp2(s->a[k],s->b[k],F[k]/((double)af->data->rate),Q);
-
- // Calculate how much this plugin adds to the overall time delay
- af->delay = 2 * af->data->nch * af->data->bps;
-@@ -209,9 +209,9 @@
- // Run the filters
- for(;k<s->K;k++){
- // Pointer to circular buffer wq
-- register float* wq = s->wq[ci][k];
-+ double* wq = s->wq[ci][k];
- // Calculate output from AR part of current filter
-- register float w=yt*s->b[k][0] + wq[0]*s->a[k][0] + wq[1]*s->a[k][1];
-+ double w=yt*s->b[k][0] + wq[0]*s->a[k][0] + wq[1]*s->a[k][1];
- // Calculate output form MA part of current filter
- yt+=(w + wq[1]*s->b[k][1])*g[k];
- // Update circular buffer
diff --git a/media-video/mplayer/mplayer-9999-r120930.ebuild b/media-video/mplayer/mplayer-9999-r120930.ebuild
deleted file mode 100644
index 3caa83c..0000000
--- a/media-video/mplayer/mplayer-9999-r120930.ebuild
+++ /dev/null
@@ -1,728 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-9999.ebuild,v 1.105 2011/07/08 10:10:07 ssuominen Exp $
-
-EAPI=4
-
-EGIT_REPO_URI="git://git.videolan.org/ffmpeg.git"
-ESVN_REPO_URI="svn://svn.mplayerhq.hu/mplayer/trunk"
-[[ ${PV} = *9999* ]] && SVN_ECLASS="subversion git-2" || SVN_ECLASS=""
-
-inherit toolchain-funcs eutils flag-o-matic multilib base ${SVN_ECLASS}
-
-# BUMP ME PLZ, NO COOKIES OTHERWISE
-[[ ${PV} != *9999* ]] && MPLAYER_REVISION=SVN-r33094
-
-IUSE="3dnow 3dnowext +a52 aalib +alsa altivec aqua +ass bidi bindist bl bluray
-bs2b cddb +cdio cdparanoia cpudetection custom-cpuopts debug dga
-directfb doc +dts +dv dvb +dvd +dvdnav dxr3 +enca +encode esd faac +faad fbcon
-ftp gif ggi gsm +iconv ipv6 jack joystick jpeg jpeg2k kernel_linux ladspa
-libcaca libmpeg2 lirc +live lzo mad md5sum +mmx mmxext mng +mp3 mpg123 nas
-+network nut openal +opengl +osdmenu oss png pnm pulseaudio pvr +quicktime
-radio +rar +real +rtc rtmp samba +shm sdl +speex sse sse2 ssse3
-tga +theora +tremor +truetype +toolame +twolame +unicode v4l v4l2 vdpau vidix
-+vorbis win32codecs +X +x264 xanim xinerama +xscreensaver +xv +xvid xvmc
-zoran"
-
-VIDEO_CARDS="s3virge mga tdfx vesa"
-for x in ${VIDEO_CARDS}; do
- IUSE+=" video_cards_${x}"
-done
-
-FONT_URI="
- mirror://mplayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
- mirror://mplayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
- mirror://mplayer/releases/fonts/font-arial-cp1250.tar.bz2
-"
-if [[ ${PV} == *9999* ]]; then
- RELEASE_URI=""
-else
- RELEASE_URI="http://dev.gentoo.org/~scarabeus/${P}.tar.xz
- mirror://gentoo/${P}.tar.xz"
-fi
-SRC_URI="${RELEASE_URI}
- !truetype? ( ${FONT_URI} )"
-
-DESCRIPTION="Media Player for Linux with modified equalizer"
-HOMEPAGE="http://www.mplayerhq.hu/"
-
-FONT_RDEPS="
- virtual/ttf-fonts
- media-libs/fontconfig
- >=media-libs/freetype-2.2.1:2
-"
-X_RDEPS="
- x11-libs/libXext
- x11-libs/libXxf86vm
-"
-# Rar: althrought -gpl version is nice, it cant do most functions normal rars can
-# nemesi? ( net-libs/libnemesi )
-RDEPEND+="
- sys-libs/ncurses
- app-arch/bzip2
- sys-libs/zlib
- !bindist? (
- x86? (
- win32codecs? ( media-libs/win32codecs )
- )
- )
- X? (
- ${X_RDEPS}
- dga? ( x11-libs/libXxf86dga )
- ggi? (
- media-libs/libggi
- media-libs/libggiwmh
- )
- opengl? ( virtual/opengl )
- vdpau? ( x11-libs/libvdpau )
- xinerama? ( x11-libs/libXinerama )
- xscreensaver? ( x11-libs/libXScrnSaver )
- xv? (
- x11-libs/libXv
- xvmc? ( x11-libs/libXvMC )
- )
- )
- a52? ( media-libs/a52dec )
- aalib? ( media-libs/aalib )
- alsa? ( media-libs/alsa-lib )
- ass? ( ${FONT_RDEPS} >=media-libs/libass-0.9.10[enca?] )
- bidi? ( dev-libs/fribidi )
- bluray? ( media-libs/libbluray )
- bs2b? ( media-libs/libbs2b )
- cdio? ( dev-libs/libcdio )
- cdparanoia? ( !cdio? ( media-sound/cdparanoia ) )
- directfb? ( dev-libs/DirectFB )
- dts? ( media-libs/libdca )
- dv? ( media-libs/libdv )
- dvd? (
- >=media-libs/libdvdread-4.1.3
- dvdnav? ( >=media-libs/libdvdnav-4.1.3 )
- )
- encode? (
- !twolame? ( toolame? ( media-sound/toolame ) )
- twolame? ( media-sound/twolame )
- faac? ( !bindist? ( media-libs/faac ) )
- mp3? ( media-sound/lame )
- x264? ( >=media-libs/x264-0.0.20100423 )
- xvid? ( media-libs/xvid )
- )
- esd? ( media-sound/esound )
- enca? ( app-i18n/enca )
- faad? ( media-libs/faad2 )
- gif? ( media-libs/giflib )
- gsm? ( media-sound/gsm )
- iconv? ( virtual/libiconv )
- jack? ( media-sound/jack-audio-connection-kit )
- jpeg? ( virtual/jpeg )
- jpeg2k? ( media-libs/openjpeg )
- ladspa? ( media-libs/ladspa-sdk )
- libcaca? ( media-libs/libcaca )
- libmpeg2? ( media-libs/libmpeg2 )
- lirc? ( app-misc/lirc )
- live? ( media-plugins/live )
- lzo? ( >=dev-libs/lzo-2 )
- mad? ( media-libs/libmad )
- mng? ( media-libs/libmng )
- mpg123? ( media-sound/mpg123 )
- nas? ( media-libs/nas )
- nut? ( >=media-libs/libnut-661 )
- openal? ( media-libs/openal )
- png? ( media-libs/libpng )
- pnm? ( media-libs/netpbm )
- pulseaudio? ( media-sound/pulseaudio )
- rar? (
- || (
- app-arch/unrar
- app-arch/rar
- )
- )
- rtmp? ( media-video/rtmpdump )
- samba? ( net-fs/samba )
- sdl? ( media-libs/libsdl )
- speex? ( media-libs/speex )
- theora? ( media-libs/libtheora[encode?] )
- truetype? ( ${FONT_RDEPS} )
- vorbis? ( media-libs/libvorbis )
- xanim? ( media-video/xanim )
-"
-
-X_DEPS="
- x11-proto/videoproto
- x11-proto/xf86vidmodeproto
-"
-ASM_DEP="dev-lang/yasm"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- X? (
- ${X_DEPS}
- dga? ( x11-proto/xf86dgaproto )
- dxr3? ( media-video/em8300-libraries )
- xinerama? ( x11-proto/xineramaproto )
- xscreensaver? ( x11-proto/scrnsaverproto )
- )
- amd64? ( ${ASM_DEP} )
- doc? (
- dev-libs/libxslt app-text/docbook-xml-dtd
- app-text/docbook-xsl-stylesheets
- )
- x86? ( ${ASM_DEP} )
- x86-fbsd? ( ${ASM_DEP} )
-"
-
-SLOT="0"
-LICENSE="GPL-2"
-if [[ ${PV} != *9999* ]]; then
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-else
- KEYWORDS=""
-fi
-
-# faac codecs are nonfree, win32codecs are nonfree
-# libcdio support: prefer libcdio over cdparanoia and don't check for cddb w/cdio
-# dvd navigation requires dvd read support
-# ass and freetype font require iconv and ass requires freetype fonts
-# unicode transformations are usefull only with iconv
-# libvorbis require external tremor to work
-# radio requires oss or alsa backend
-# xvmc requires xvideo support
-REQUIRED_USE="bindist? ( !faac !win32codecs )"
-
-PATCHES=(
-)
-
-pkg_setup() {
- if [[ ${PV} == *9999* ]]; then
- elog
- elog "This is a live ebuild which installs the latest from upstream's"
- elog "subversion repository, and is unsupported by Gentoo."
- elog "Everything but bugs in the ebuild itself will be ignored."
- elog
- fi
-
- if use cpudetection; then
- ewarn
- ewarn "You've enabled the cpudetection flag. This feature is"
- ewarn "included mainly for people who want to use the same"
- ewarn "binary on another system with a different CPU architecture."
- ewarn "MPlayer will already detect your CPU settings by default at"
- ewarn "buildtime; this flag is used for runtime detection."
- ewarn "You won't need this turned on if you are only building"
- ewarn "mplayer for this system. Also, if your compile fails, try"
- ewarn "disabling this use flag."
- fi
-
- if use custom-cpuopts; then
- ewarn
- ewarn "You are using the custom-cpuopts flag which will"
- ewarn "specifically allow you to enable / disable certain"
- ewarn "CPU optimizations."
- ewarn
- ewarn "Most desktop users won't need this functionality, but it"
- ewarn "is included for corner cases like cross-compiling and"
- ewarn "certain profiles. If unsure, disable this flag and MPlayer"
- ewarn "will automatically detect and use your available CPU"
- ewarn "optimizations."
- ewarn
- ewarn "Using this flag means your build is unsupported, so"
- ewarn "please make sure your CPU optimization use flags (3dnow"
- ewarn "3dnowext mmx mmxext sse sse2 ssse3) are properly set."
- fi
-}
-
-src_unpack() {
- if [[ ${PV} = *9999* ]]; then
- subversion_src_unpack
- cd "${WORKDIR}"
- rm -rf "${WORKDIR}/${P}/ffmpeg/"
- ( S="${WORKDIR}/${P}/ffmpeg/" git-2_src_unpack )
- cd "${S}"
- #cp "${FILESDIR}/dump_ffmpeg.sh" . || die
- #chmod +x dump_ffmpeg.sh
- #./dump_ffmpeg.sh || die
- else
- unpack ${A}
- fi
-
- if ! use truetype; then
- unpack font-arial-iso-8859-1.tar.bz2 \
- font-arial-iso-8859-2.tar.bz2 \
- font-arial-cp1250.tar.bz2
- fi
-}
-
-src_prepare() {
- if [[ ${PV} = *9999* ]]; then
- # Set SVN version manually
- subversion_wc_info
- sed -i -e "s/UNKNOWN/${ESVN_WC_REVISION}/" "${S}/version.sh" || die
- else
- # Set version #
- sed -i -e "s/UNKNOWN/${MPLAYER_REVISION}/" "${S}/version.sh" || die
- fi
-
- # fix path to bash executable in configure scripts
- sed -i -e "1c\#!${EPREFIX}/bin/bash" configure version.sh || die
-
- base_src_prepare
- epatch "${FILESDIR}"/af_equalizer.c.diff
-}
-
-src_configure() {
- local myconf=""
- local uses i
-
- # set LINGUAS
- [[ -n $LINGUAS ]] && LINGUAS="${LINGUAS/da/dk}"
-
- # mplayer ebuild uses "use foo || --disable-foo" to forcibly disable
- # compilation in almost every situation. The reason for this is
- # because if --enable is used, it will force the build of that option,
- # regardless of whether the dependency is available or not.
-
- ###################
- #Optional features#
- ###################
- # disable svga since we don't want it
- # disable arts since we don't have kde3
- # always disable internal ass
- myconf+="
- --disable-svga --disable-svgalib_helper
- --disable-ass-internal
- --disable-arts
- --disable-kai
- $(use_enable network networking)
- $(use_enable joystick)
- "
- uses="ass bl bluray enca ftp rtc" # nemesi <- not working with in-tree ebuild
- myconf+=" --disable-nemesi" # nemesi automagic disable
- for i in ${uses}; do
- use ${i} || myconf+=" --disable-${i}"
- done
- use bidi || myconf+=" --disable-fribidi"
- use ipv6 || myconf+=" --disable-inet6"
- use nut || myconf+=" --disable-libnut"
- use rar || myconf+=" --disable-unrarexec"
- use samba || myconf+=" --disable-smb"
- if ! use lirc; then
- myconf+="
- --disable-lirc
- --disable-lircc
- --disable-apple-ir
- "
- fi
-
- # libcdio support: prefer libcdio over cdparanoia
- # don't check for cddb w/cdio
- if use cdio; then
- myconf+=" --disable-cdparanoia"
- else
- myconf+=" --disable-libcdio"
- use cdparanoia || myconf+=" --disable-cdparanoia"
- use cddb || myconf+=" --disable-cddb"
- fi
-
- ################################
- # DVD read, navigation support #
- ################################
- #
- # dvdread - accessing a DVD
- # dvdnav - navigation of menus
- #
- # use external libdvdcss, dvdread and dvdnav
- myconf+=" --disable-dvdread-internal --disable-libdvdcss-internal"
- if use dvd; then
- use dvdnav || myconf+=" --disable-dvdnav"
- else
- myconf+="
- --disable-dvdnav
- --disable-dvdread
- "
- fi
-
- #############
- # Subtitles #
- #############
- #
- # SRT/ASS/SSA (subtitles) requires freetype support
- # freetype support requires iconv
- # iconv optionally can use unicode
- if ! use ass && ! use truetype; then
- myconf+=" --disable-freetype"
- if ! use iconv; then
- myconf+="
- --disable-iconv
- --charset=noconv
- "
- fi
- fi
- use iconv && use unicode && myconf+=" --charset=UTF-8"
-
- #####################################
- # DVB / Video4Linux / Radio support #
- #####################################
- myconf+=" --disable-tv-bsdbt848"
- # broken upstream, won't work with recent kernels
- myconf+=" --disable-ivtv"
- if { use dvb || use v4l || use v4l2 || use pvr || use radio; }; then
- use dvb || myconf+=" --disable-dvb"
- use pvr || myconf+=" --disable-pvr"
- use v4l || myconf+=" --disable-tv-v4l1"
- use v4l2 || myconf+=" --disable-tv-v4l2"
- if use radio && { use dvb || use v4l || use v4l2; }; then
- myconf+="
- --enable-radio
- $(use_enable encode radio-capture)
- "
- else
- myconf+="
- --disable-radio-v4l2
- --disable-radio-bsdbt848
- "
- fi
- else
- myconf+="
- --disable-tv
- --disable-tv-v4l1
- --disable-tv-v4l2
- --disable-radio
- --disable-radio-v4l2
- --disable-radio-bsdbt848
- --disable-dvb
- --disable-v4l2
- --disable-pvr"
- fi
-
- ##########
- # Codecs #
- ##########
- myconf+=" --disable-musepack" # Use internal musepack codecs for SV7 and SV8 support
- myconf+=" --disable-libmpeg2-internal" # always use system media-libs/libmpeg2
- use dts || myconf+=" --disable-libdca"
- if ! use mp3; then
- myconf+="
- --disable-mp3lame
- --disable-mp3lib
- "
- fi
- uses="a52 bs2b dv gsm lzo rtmp"
- for i in ${uses}; do
- use ${i} || myconf+=" --disable-lib${i}"
- done
-
- uses="faad gif jpeg libmpeg2 live mad mng mpg123 png pnm speex tga theora xanim"
- for i in ${uses}; do
- use ${i} || myconf+=" --disable-${i}"
- done
- use jpeg2k || myconf+=" --disable-libopenjpeg"
- if use vorbis || use tremor; then
- use vorbis || myconf+=" --disable-libvorbis"
- else
- myconf+="
- --disable-tremor-internal
- --disable-tremor
- --disable-libvorbis
- "
- fi
- # Encoding
- uses="faac x264 xvid toolame twolame"
- if use encode; then
- for i in ${uses}; do
- use ${i} || myconf+=" --disable-${i}"
- done
- if use bindist && use faac; then
- ewarn "faac is nonfree and cannot be distributed; disabling faac support."
- myconf+=" --disable-faac"
- fi
- else
- myconf+=" --disable-mencoder"
- for i in ${uses}; do
- myconf+=" --disable-${i}"
- use ${i} && elog "Useflag \"${i}\" require \"encode\" useflag enabled to work."
- done
- fi
-
- #################
- # Binary codecs #
- #################
- # bug 213836
- if ! use x86 || ! use win32codecs; then
- use quicktime || myconf+=" --disable-qtx"
- fi
-
- ######################
- # RealPlayer support #
- ######################
- # Realplayer support shows up in four places:
- # - libavcodec (internal)
- # - win32codecs
- # - realcodecs (win32codecs libs)
- # - realcodecs (realplayer libs)
-
- # internal
- use real || myconf+=" --disable-real"
-
- # Real binary codec support only available on x86, amd64
- if use real; then
- use x86 && myconf+=" --codecsdir=/opt/RealPlayer/codecs"
- use amd64 && myconf+=" --codecsdir=/usr/$(get_libdir)/codecs"
- fi
- myconf+=" $(use_enable win32codecs win32dll)"
-
- ################
- # Video Output #
- ################
- uses="directfb md5sum sdl"
- for i in ${uses}; do
- use ${i} || myconf+=" --disable-${i}"
- done
- use aalib || myconf+=" --disable-aa"
- use fbcon || myconf+=" --disable-fbdev"
- use fbcon && use video_cards_s3virge && myconf+=" --enable-s3fb"
- use libcaca || myconf+=" --disable-caca"
- use zoran || myconf+=" --disable-zr"
-
- if ! use kernel_linux || ! use video_cards_mga; then
- myconf+=" --disable-mga --disable-xmga"
- fi
-
- if use video_cards_tdfx; then
- myconf+="
- $(use_enable video_cards_tdfx tdfxvid)
- $(use_enable fbcon tdfxfb)
- "
- else
- myconf+="
- --disable-3dfx
- --disable-tdfxvid
- --disable-tdfxfb
- "
- fi
-
- # sun card, disable by default, see bug #258729
- myconf+=" --disable-xvr100"
-
- ################
- # Audio Output #
- ################
- uses="alsa esd jack ladspa nas openal"
- for i in ${uses}; do
- use ${i} || myconf+=" --disable-${i}"
- done
- use pulseaudio || myconf+=" --disable-pulse"
- if ! use radio; then
- use oss || myconf+=" --disable-ossaudio"
- fi
-
- ####################
- # Advanced Options #
- ####################
- # Platform specific flags, hardcoded on amd64 (see below)
- use cpudetection && myconf+=" --enable-runtime-cpudetection"
-
- # Turning off CPU optimizations usually will break the build.
- # However, this use flag, if enabled, will allow users to completely
- # specify which ones to use. If disabled, mplayer will automatically
- # enable all CPU optimizations that the host build supports.
- if use custom-cpuopts; then
- uses="3dnow 3dnowext altivec mmx mmxext shm sse sse2 ssse3"
- for i in ${uses}; do
- myconf+=" $(use_enable ${i})"
- done
- fi
-
- use debug && myconf+=" --enable-debug=3"
-
- if use x86 && gcc-specs-pie; then
- filter-flags -fPIC -fPIE
- append-ldflags -nopie
- fi
-
- is-flag -O? || append-flags -O2
-
- # workaround bug, x86 just has too few registers, see c.f.
- # http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=402950#44
- # and 32-bits OSX, bug 329861
- if [[ ${CHOST} == i?86-* ]] ; then
- use debug || append-flags -fomit-frame-pointer
- fi
-
- ###########################
- # X enabled configuration #
- ###########################
- myconf+=" --disable-gui"
- if use X; then
- uses="dxr3 ggi xinerama"
- for i in ${uses}; do
- use ${i} || myconf+=" --disable-${i}"
- done
- use dga || myconf+=" --disable-dga1 --disable-dga2"
- use opengl || myconf+=" --disable-gl"
- use osdmenu && myconf+=" --enable-menu"
- use vdpau || myconf+=" --disable-vdpau"
- use video_cards_vesa || myconf+=" --disable-vesa"
- use vidix || myconf+=" --disable-vidix --disable-vidix-pcidb"
- use xscreensaver || myconf+=" --disable-xss"
-
- if use xv; then
- if use xvmc; then
- myconf+=" --enable-xvmc --with-xvmclib=XvMCW"
- else
- myconf+=" --disable-xvmc"
- fi
- else
- myconf+="
- --disable-xv
- --disable-xvmc
- "
- use xvmc && elog "Disabling xvmc because it requires \"xv\" useflag enabled."
- fi
- else
- myconf+="
- --disable-dga1
- --disable-dga2
- --disable-dxr3
- --disable-ggi
- --disable-gl
- --disable-vdpau
- --disable-vidix
- --disable-vidix-pcidb
- --disable-xinerama
- --disable-xss
- --disable-xv
- --disable-xvmc
- --disable-x11
- "
- uses="dga dxr3 ggi opengl osdmenu vdpau vidix xinerama xscreensaver xv"
- for i in ${uses}; do
- use ${i} && elog "Useflag \"${i}\" require \"X\" useflag enabled to work."
- done
- fi
-
- ############################
- # OSX (aqua) configuration #
- ############################
- if use aqua; then
- myconf+="
- --enable-macosx-finder
- --enable-macosx-bundle
- "
- fi
- #--disable-ffmpeg_a \
-
- ./configure \
- --cc="$(tc-getCC)" \
- --host-cc="$(tc-getBUILD_CC)" \
- --prefix="${EPREFIX}/usr" \
- --bindir="${EPREFIX}/usr/bin" \
- --libdir="${EPREFIX}/usr/$(get_libdir)" \
- --confdir="${EPREFIX}/etc/mplayer" \
- --datadir="${EPREFIX}/usr/share/mplayer${namesuf}" \
- --mandir="${EPREFIX}/usr/share/man" \
- ${myconf} || die
-}
-
-src_compile() {
- base_src_compile
- # Build only user-requested docs if they're available.
- if use doc ; then
- # select available languages from $LINGUAS
- LINGUAS=${LINGUAS/zh/zh_CN}
- local ALLOWED_LINGUAS="cs de en es fr hu it pl ru zh_CN"
- local BUILT_DOCS=""
- for i in ${LINGUAS} ; do
- has ${i} ${ALLOWED_LINGUAS} && BUILT_DOCS+=" ${i}"
- done
- if [[ -z $BUILT_DOCS ]]; then
- emake -j1 -C DOCS/xml html-chunked
- else
- for i in ${BUILT_DOCS}; do
- emake -j1 -C DOCS/xml html-chunked-${i}
- done
- fi
- fi
-}
-
-src_install() {
- local i
-
- emake \
- DESTDIR="${D}" \
- INSTALLSTRIP="" \
- install
-
- dodoc AUTHORS Changelog Copyright README etc/codecs.conf
-
- docinto tech/
- dodoc DOCS/tech/{*.txt,MAINTAINERS,mpsub.sub,playtree,TODO,wishlist}
- docinto TOOLS/
- dodoc -r TOOLS
- if use real; then
- docinto tech/realcodecs/
- dodoc DOCS/tech/realcodecs/*
- fi
- docinto tech/mirrors/
- dodoc DOCS/tech/mirrors/*
-
- if use doc; then
- docinto html/
- dohtml -r "${S}"/DOCS/HTML/*
- fi
-
- if ! use ass && ! use truetype; then
- dodir /usr/share/mplayer/fonts
- # Do this generic, as the mplayer people like to change the structure
- # of their zips ...
- for i in $(find "${WORKDIR}/" -type d -name 'font-arial-*'); do
- cp -pPR "${i}" "${ED}/usr/share/mplayer/fonts"
- done
- # Fix the font symlink ...
- rm -rf "${ED}/usr/share/mplayer/font"
- dosym fonts/font-arial-14-iso-8859-1 /usr/share/mplayer/font
- fi
-
- insinto /etc/mplayer
- newins "${S}/etc/example.conf" mplayer.conf
- cat >> "${ED}/etc/mplayer/mplayer.conf" << _EOF_
-# Config options can be section specific, global
-# options should go in the default section
-[default]
-_EOF_
- doins "${S}/etc/input.conf"
- if use osdmenu; then
- doins "${S}/etc/menu.conf"
- fi
-
- if use ass || use truetype; then
- cat >> "${ED}/etc/mplayer/mplayer.conf" << _EOF_
-fontconfig=1
-subfont-osd-scale=4
-subfont-text-scale=3
-_EOF_
- fi
-
- # bug 256203
- if use rar; then
- cat >> "${ED}/etc/mplayer/mplayer.conf" << _EOF_
-unrarexec=${EPREFIX}/usr/bin/unrar
-_EOF_
- fi
-
- dosym ../../../etc/mplayer/mplayer.conf /usr/share/mplayer/mplayer.conf
- newbin "${S}/TOOLS/midentify.sh" midentify
-}
-
-pkg_preinst() {
- [[ -d ${EROOT}/usr/share/mplayer/Skin/default ]] && \
- rm -rf "${EROOT}/usr/share/mplayer/Skin/default"
-}
-
-pkg_postrm() {
- # Cleanup stale symlinks
- [ -L "${EROOT}/usr/share/mplayer/font" -a \
- ! -e "${EROOT}/usr/share/mplayer/font" ] && \
- rm -f "${EROOT}/usr/share/mplayer/font"
-
- [ -L "${EROOT}/usr/share/mplayer/subfont.ttf" -a \
- ! -e "${EROOT}/usr/share/mplayer/subfont.ttf" ] && \
- rm -f "${EROOT}/usr/share/mplayer/subfont.ttf"
-}