summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Kuhn (Wuodan) <wuodan-gentoo@hispeed.ch>2012-12-15 15:20:43 +0100
committerStefan Kuhn (Wuodan) <wuodan-gentoo@hispeed.ch>2012-12-15 15:20:43 +0100
commitd12f131900d84d1ad2ec04320195bdab7d89b397 (patch)
tree0e117da51d710c8f4a45133e04106c7897d4649a
parentsys-firmware/edk2-efishell-bin: ebuild fetches the binary from edk2 repo/website (diff)
downloadwuodan-d12f131900d84d1ad2ec04320195bdab7d89b397.tar.gz
wuodan-d12f131900d84d1ad2ec04320195bdab7d89b397.tar.bz2
wuodan-d12f131900d84d1ad2ec04320195bdab7d89b397.zip
sys-firmware/edk2-*: added ebuilds for binaries
-rw-r--r--sys-firmware/edk2-bin/Manifest3
-rw-r--r--sys-firmware/edk2-bin/edk2-bin-9999-r11337.ebuild53
-rw-r--r--sys-firmware/edk2-bin/metadata.xml18
-rw-r--r--sys-firmware/edk2/Manifest4
-rw-r--r--sys-firmware/edk2/edk2-9999-r11337.ebuild4
-rw-r--r--sys-firmware/edk2/metadata.xml4
6 files changed, 80 insertions, 6 deletions
diff --git a/sys-firmware/edk2-bin/Manifest b/sys-firmware/edk2-bin/Manifest
new file mode 100644
index 0000000..c9aca27
--- /dev/null
+++ b/sys-firmware/edk2-bin/Manifest
@@ -0,0 +1,3 @@
+DIST edk2-bin-9999-r11337.tar.gz 750518 SHA256 8d29be4b875e912538a39d2531acb08f7fb71e23812aa3f7fc5e8063a15343a1 SHA512 f11163d766cb7a9daee710a816acb7e9fd23649fe2cb2ac5e6124616f696b2e2a4dd86275cb09fc9575836c3ed815ce972a3f5ff45f27150e26ada24a366606d WHIRLPOOL 35511df9333e01e052fe583cc665e4c3c28821462772db8997873582372d71a8658ec4728cd303e33311e928133664744f73977dec51a65a557d75c2a9677fa0
+EBUILD edk2-bin-9999-r11337.ebuild 1414 SHA256 f5f05ccb8e122e7377935866243463dd56926ba2702e8b4a51592d47d6deb04c SHA512 ec2dee0995f9d3b761be97b255d13b5f06b83376343e5bf6767ba58efbe863addaf554f1d003fcc1d964132b8181e9d74bc6acd6398ff276be8b7ace212bf3de WHIRLPOOL 251527f9e6534ad7ea596710eab7b4574863320eec9adcf1a8841e812f84ff5b715c23df92a26004068cc48bf0cf7e34b28b6129f6faa675b438f4585c41c432
+MISC metadata.xml 671 SHA256 d601a51880404882d70005218c430dbc76dd824d8f192f931f7837f6056d5fa7 SHA512 dcae1caa30d0daac3bc93cbd0a58c080da912b81df7e9efc6b17c5343bd592bef8ff0a7ef5f90390f88c555aec5b456587351976ce4f584e02c631dff04d9732 WHIRLPOOL 4fd2b31bdbe469df0aac5bb74568f48f0649806da20a9596fb624ee15091672375e868ff7e28c35177e51cd177d5ef2c0ab5f9aad0d250e412deee32f69ba8a0
diff --git a/sys-firmware/edk2-bin/edk2-bin-9999-r11337.ebuild b/sys-firmware/edk2-bin/edk2-bin-9999-r11337.ebuild
new file mode 100644
index 0000000..caa0be0
--- /dev/null
+++ b/sys-firmware/edk2-bin/edk2-bin-9999-r11337.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DESCRIPTION="Binaries for the EDK2 plattform (UEFI tools)"
+HOMEPAGE="http://sourceforge.net/apps/mediawiki/tianocore"
+SRC_URI="http://pentoo-uefi.googlecode.com/files/${PF}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="hello-world kvm shell"
+REQUIRED_USE="|| ( hello-world kvm shell )"
+
+DEPEND=""
+RDEPEND="kvm? ( >=app-emulation/qemu-0.9.1 )"
+
+# S="$(dirname ${S})"
+S="${WORKDIR}/${PF}"
+
+src_install(){
+ if use hello-world; then
+ insinto "/usr/share/${PN}/hello-world"
+ doins "HelloWorld.efi"
+ doins "startup.nsh"
+ fi
+
+ if use kvm; then
+ insinto "/usr/share/${PN}/kvm"
+ newins OVMF.fd uefibios.bin
+ newins CirrusLogic5446.rom vgabios-cirrus.bin
+ dosym "../${PN}/kvm/uefibios.bin" /usr/share/qemu/uefibios-bin.bin
+ fi
+
+ if use shell; then
+ insinto "/usr/share/${PN}/shell"
+ newins Shell.efi Shellx64.efi
+ fi
+}
+
+pkg_postinst() {
+ use kvm && einfo "To use uefi with qemu, start it with '-bios uefibios.bin'"
+ if use hello-world; then
+ einfo "A sample HelloWorld.efi was installed in /usr/share/${PN}/hello-world."
+ if use kvm; then
+ einfo "To test the uefi support in kvm, simply run:"
+ einfo " qemu-kvm -hda fat:/usr/share/${PN}/hello-world -bios uefibios-bin.bin"
+ einfo "and await the message 'UEFI Hello World!' before the shell prompt appears."
+ fi
+ fi
+}
diff --git a/sys-firmware/edk2-bin/metadata.xml b/sys-firmware/edk2-bin/metadata.xml
new file mode 100644
index 0000000..c01efac
--- /dev/null
+++ b/sys-firmware/edk2-bin/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-wanted@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+These are sample binaries - use at own risk!
+EDK II is a modern, feature-rich, cross-platform firmware development
+environment for the UEFI and PI specifications.
+</longdescription>
+<use>
+<flag name="hello-world">Creates a HelloWorld.efi, ready to use with
+<pkg>app-emulation/qemu</pkg>.</flag>
+<flag name="kvm">Creates the uefi-bios for <pkg>app-emulation/qemu</pkg>.</flag>
+<flag name="shell">Creates the uefi-shell.</flag>
+</use>
+</pkgmetadata>
diff --git a/sys-firmware/edk2/Manifest b/sys-firmware/edk2/Manifest
index 2cfd838..fc553dc 100644
--- a/sys-firmware/edk2/Manifest
+++ b/sys-firmware/edk2/Manifest
@@ -1,2 +1,2 @@
-EBUILD edk2-9999-r11337.ebuild 6355 SHA256 1947b6c0356283da6360d9dd51be703b951e0eaccb52ac4450f7fbcc6e076504 SHA512 b703162b7b60f6d9a5e69eb57d82c9e5638ccbe449cc5b887ab73e5ec53b31f262488ab1dbf7080557a2d1a0673340cfed7b99a30c3779d02232247b25aedd34 WHIRLPOOL ddbc0412d639594fa3913b382f75804f4b01df5a38059fda5355ba903ccdec5021c99e184b78c83c6661739228b90b639d61a5752578fc69036d292a4ecbd187
-MISC metadata.xml 634 SHA256 926504f700c193cd127263da7e38869bbc5a79260811fd0ebb49097d576e5191 SHA512 184cbcc668a57b07238e13fa7a4c3a15cb9c277265bd3071324e97d7f9c89a7a5eff37e393335a338381d7ee3cdb2626495f9e91b53b3fc06cf77b0fc36d45a8 WHIRLPOOL 7dc634a6befd693939988d936abb225861b2a6077084edfa64df1150e9b2054f11c33ee108faa5588395dfcdefe6056ab74f16ddd46cec096b04731afbe7b0da
+EBUILD edk2-9999-r11337.ebuild 6352 SHA256 43a663619ff2144e81b4a17ab527ca226535984ab73735b178efbf1d070a9d93 SHA512 c8969c0670c9490812e9178c80d9c6d075023d3a213b2e38af5d0611210f3089f46c7265ab708cc93ff0a5e648bcf8247be70d3ce9d574a0b20788491c184e04 WHIRLPOOL 37458d6e386d1b6cf982a7958908e70d0d1ce6bdc19e1687098c386e6350db66554dfbe052013b501cdafc65372a0863753e45949e5e066269ed3f7cadf7a552
+MISC metadata.xml 626 SHA256 9cc1ab2c024ace64cc357bfd5c2b8c6c895c742eceff28474b1ba37fd12d2927 SHA512 b356ef114162aed2cf44a34643ea98e34a78589d3a415cc60112f6915ec4fb099640447715f52a7ae65f08ba12a20f97b86906903fd04e05ca9a39f1f16c72e8 WHIRLPOOL 84830f9d816beeb83d7c743469bf360433006ae5d2eaef9f479d87127b555410442ce7f5bf29b6f207408a28a1fdc6c3c444a77c32d9e5da479c76042f926fe6
diff --git a/sys-firmware/edk2/edk2-9999-r11337.ebuild b/sys-firmware/edk2/edk2-9999-r11337.ebuild
index 49299af..e991c48 100644
--- a/sys-firmware/edk2/edk2-9999-r11337.ebuild
+++ b/sys-firmware/edk2/edk2-9999-r11337.ebuild
@@ -178,12 +178,12 @@ src_install(){
}
pkg_postinst() {
- use kvm && einfo "To use uefi with qemu-kvm, start it with '-bios uefibios.bin'"
+ use kvm && einfo "To use uefi with qemu, start it with '-bios uefibios.bin'"
if use hello-world; then
einfo "A sample HelloWorld.efi was installed in /usr/share/${PN}/hello-world."
if use kvm; then
einfo "To test the uefi support in kvm, simply run:"
- einfo " qemu-kvm -hda fat:/usr/share/edk2/hello-world -bios uefibios.bin"
+ einfo " qemu-kvm -hda fat:/usr/share/${PN}/hello-world -bios uefibios.bin"
einfo "and await the message 'UEFI Hello World!' before the shell prompt appears."
fi
fi
diff --git a/sys-firmware/edk2/metadata.xml b/sys-firmware/edk2/metadata.xml
index 3dbd636..4bab2fc 100644
--- a/sys-firmware/edk2/metadata.xml
+++ b/sys-firmware/edk2/metadata.xml
@@ -10,8 +10,8 @@ environment for the UEFI and PI specifications.
</longdescription>
<use>
<flag name="hello-world">Creates a HelloWorld.efi, ready to use with
-<pkg>app-emulation/qemu-kvm</pkg>.</flag>
-<flag name="kvm">Creates the uefi-bios for <pkg>app-emulation/qemu-kvm</pkg>.</flag>
+<pkg>app-emulation/qemu</pkg>.</flag>
+<flag name="kvm">Creates the uefi-bios for <pkg>app-emulation/qemu</pkg>.</flag>
<flag name="shell">Creates the uefi-shell.</flag>
</use>
</pkgmetadata>