summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-firmware/edk2-bin/edk2-bin-9999-r11337.ebuild')
-rw-r--r--sys-firmware/edk2-bin/edk2-bin-9999-r11337.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/sys-firmware/edk2-bin/edk2-bin-9999-r11337.ebuild b/sys-firmware/edk2-bin/edk2-bin-9999-r11337.ebuild
index caa0be0..bd36458 100644
--- a/sys-firmware/edk2-bin/edk2-bin-9999-r11337.ebuild
+++ b/sys-firmware/edk2-bin/edk2-bin-9999-r11337.ebuild
@@ -11,11 +11,11 @@ SRC_URI="http://pentoo-uefi.googlecode.com/files/${PF}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="hello-world kvm shell"
-REQUIRED_USE="|| ( hello-world kvm shell )"
+IUSE="hello-world qemu shell"
+REQUIRED_USE="|| ( hello-world qemu shell )"
DEPEND=""
-RDEPEND="kvm? ( >=app-emulation/qemu-0.9.1 )"
+RDEPEND="qemu? ( >=app-emulation/qemu-0.9.1 )"
# S="$(dirname ${S})"
S="${WORKDIR}/${PF}"
@@ -27,11 +27,11 @@ src_install(){
doins "startup.nsh"
fi
- if use kvm; then
- insinto "/usr/share/${PN}/kvm"
+ if use qemu; then
+ insinto "/usr/share/${PN}/qemu"
newins OVMF.fd uefibios.bin
newins CirrusLogic5446.rom vgabios-cirrus.bin
- dosym "../${PN}/kvm/uefibios.bin" /usr/share/qemu/uefibios-bin.bin
+ dosym "../${PN}/qemu/uefibios.bin" /usr/share/qemu/uefibios-bin.bin
fi
if use shell; then
@@ -41,11 +41,11 @@ src_install(){
}
pkg_postinst() {
- use kvm && einfo "To use uefi with qemu, start it with '-bios uefibios.bin'"
+ use qemu && einfo "To use uefi with qemu, start it with '-bios uefibios.bin'"
if use hello-world; then
einfo "A sample HelloWorld.efi was installed in /usr/share/${PN}/hello-world."
- if use kvm; then
- einfo "To test the uefi support in kvm, simply run:"
+ if use qemu; then
+ einfo "To test the uefi support in qemu, simply run:"
einfo " qemu-kvm -hda fat:/usr/share/${PN}/hello-world -bios uefibios-bin.bin"
einfo "and await the message 'UEFI Hello World!' before the shell prompt appears."
fi