summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-05 03:56:45 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-05 03:56:45 +0000
commit93fa9feddbcf60616f8a085242248b776e934f32 (patch)
tree3d65fc8e7379cc104050545f2b2da44d10a82618 /games-emulation/zsnes
parentfix bug #36295, bump revision. (diff)
downloadhistorical-93fa9feddbcf60616f8a085242248b776e934f32.tar.gz
historical-93fa9feddbcf60616f8a085242248b776e934f32.tar.bz2
historical-93fa9feddbcf60616f8a085242248b776e934f32.zip
ver bump #36049
Diffstat (limited to 'games-emulation/zsnes')
-rw-r--r--games-emulation/zsnes/ChangeLog7
-rw-r--r--games-emulation/zsnes/files/digest-zsnes-1.37_pre200412201
-rw-r--r--games-emulation/zsnes/zsnes-1.37_pre20041220.ebuild52
3 files changed, 59 insertions, 1 deletions
diff --git a/games-emulation/zsnes/ChangeLog b/games-emulation/zsnes/ChangeLog
index 77b8e0d436f0..fffedcd6af49 100644
--- a/games-emulation/zsnes/ChangeLog
+++ b/games-emulation/zsnes/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/zsnes
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/ChangeLog,v 1.3 2004/01/05 02:53:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/ChangeLog,v 1.4 2004/01/05 03:56:45 vapier Exp $
+
+*zsnes-1.37_pre20041220 (04 Jan 2004)
+
+ 04 Jan 2004; Mike Frysinger <vapier@gentoo.org> :
+ Add the December 20th WIP release #36049. Would add the 23rd WIP but it's MIA.
*zsnes-1.36 (21 Jul 2002)
diff --git a/games-emulation/zsnes/files/digest-zsnes-1.37_pre20041220 b/games-emulation/zsnes/files/digest-zsnes-1.37_pre20041220
new file mode 100644
index 000000000000..e80494c9b898
--- /dev/null
+++ b/games-emulation/zsnes/files/digest-zsnes-1.37_pre20041220
@@ -0,0 +1 @@
+MD5 b0d31622b4cf9219b1bcda75842beac1 ZSNESS_1220.tar.bz2 764086
diff --git a/games-emulation/zsnes/zsnes-1.37_pre20041220.ebuild b/games-emulation/zsnes/zsnes-1.37_pre20041220.ebuild
new file mode 100644
index 000000000000..9697b628a0f9
--- /dev/null
+++ b/games-emulation/zsnes/zsnes-1.37_pre20041220.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/zsnes-1.37_pre20041220.ebuild,v 1.1 2004/01/05 03:56:45 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="SNES (Super Nintendo) emulator that uses x86 assembly"
+HOMEPAGE="http://www.zsnes.com/"
+SRC_URI="http://ipher.emuhost.com/files/zsnes/ZSNESS_${PV/*2004}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE="opengl"
+
+RDEPEND="opengl? ( virtual/opengl )
+ virtual/x11
+ >=media-libs/libsdl-1.2.0
+ sys-libs/zlib
+ media-libs/libpng"
+DEPEND="${RDEPEND}
+ >=dev-lang/nasm-0.98
+ sys-devel/automake
+ sys-devel/autoconf"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ for f in * ; do
+ mv ${f} ${f/zsnes\\\\}
+ done
+ cd src
+ edos2unix config.{guess,sub}
+ aclocal || die "aclocal failed"
+ env WANT_AUTOCONF=2.5 autoconf || die "autoconf failed"
+}
+
+src_compile() {
+ # Do NOT introduce custom ${CFLAGS}.
+ # Current choices are the optimal ones
+ cd src
+ egamesconf `use_with opengl` || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin src/zsnes
+ newman src/linux/zsnes.1 zsnes.6
+ dodoc *.txt linux/*
+ prepgamesdirs
+}