summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Doty <kingtaco@gentoo.org>2009-10-16 20:16:37 +0000
committerMike Doty <kingtaco@gentoo.org>2009-10-16 20:16:37 +0000
commitd2508f97732fdf2189c5dca2e9d68f9929225d87 (patch)
tree9aa1c20dfde3a0752273f00df599d56ae5496c3a /net-misc/rwhoisd/files
parentfix bashism in init script (bug #195939) (diff)
downloadhistorical-d2508f97732fdf2189c5dca2e9d68f9929225d87.tar.gz
historical-d2508f97732fdf2189c5dca2e9d68f9929225d87.tar.bz2
historical-d2508f97732fdf2189c5dca2e9d68f9929225d87.zip
initial import
Package-Manager: portage-2.1.7.1/cvs/Linux x86_64
Diffstat (limited to 'net-misc/rwhoisd/files')
-rw-r--r--net-misc/rwhoisd/files/rwhoisd18
-rw-r--r--net-misc/rwhoisd/files/rwhoisd-destdir.patch27
-rw-r--r--net-misc/rwhoisd/files/rwhoisd.conf8
3 files changed, 53 insertions, 0 deletions
diff --git a/net-misc/rwhoisd/files/rwhoisd b/net-misc/rwhoisd/files/rwhoisd
new file mode 100644
index 000000000000..9c3b6bd05222
--- /dev/null
+++ b/net-misc/rwhoisd/files/rwhoisd
@@ -0,0 +1,18 @@
+#!/sbin/runscript
+
+depend() {
+ use logger
+ need net
+}
+
+start() {
+ ebegin "Starting rwhoisd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/rwhoisd ${RWHOISD_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping tftpd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/rwhoisd
+ eend $?
+}
diff --git a/net-misc/rwhoisd/files/rwhoisd-destdir.patch b/net-misc/rwhoisd/files/rwhoisd-destdir.patch
new file mode 100644
index 000000000000..54369048de35
--- /dev/null
+++ b/net-misc/rwhoisd/files/rwhoisd-destdir.patch
@@ -0,0 +1,27 @@
+--- tools/rwhois_repack/Makefile.in.orig 2009-10-16 11:30:40.000000000 -0700
++++ tools/rwhois_repack/Makefile.in 2009-10-16 11:31:20.000000000 -0700
+@@ -52,9 +52,9 @@
+ # procedural
+
+ install:
+- if [ ! -d $(exec_prefix) ]; then mkdir $(exec_prefix); fi
+- if [ ! -d $(bindir) ]; then mkdir $(bindir); fi
+- $(INSTALL) rwhois_repack $(bindir)
++ if [ ! -d $(DESTDIR)$(exec_prefix) ]; then mkdir $(DESTDIR)$(exec_prefix); fi
++ if [ ! -d $(DESTDIR)$(bindir) ]; then mkdir $(DESTDIR)$(bindir); fi
++ $(INSTALL) rwhois_repack $(DESTDIR)$(bindir)
+
+ uninstall:
+ $(RM) $(bindir)/rwhois_repack
+
+--- sample.data/Makefile.in.orig 2009-10-16 11:37:54.000000000 -0700
++++ sample.data/Makefile.in 2009-10-16 11:38:22.000000000 -0700
+@@ -10,7 +10,7 @@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ bindir = $(exec_prefix)/bin
+-etcdir = $(exec_prefix)/etc
++etcdir = /etc
+
+ srcdir = @srcdir@
+ VPATH = @srcdir@
diff --git a/net-misc/rwhoisd/files/rwhoisd.conf b/net-misc/rwhoisd/files/rwhoisd.conf
new file mode 100644
index 000000000000..4715be3d632f
--- /dev/null
+++ b/net-misc/rwhoisd/files/rwhoisd.conf
@@ -0,0 +1,8 @@
+#$Header: /var/cvsroot/gentoo-x86/net-misc/rwhoisd/files/rwhoisd.conf,v 1.1 2009/10/16 20:16:37 kingtaco Exp $
+OPTS="-c /etc/rwhoisd/rwhoisd.conf"
+
+#Pass any additional options to rwhoisd here.
+
+RWHOISD_OPTS="${OPTS}"
+
+