summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-07 02:41:58 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-07 02:41:58 +0000
commitf703c6ccc732145907211d7b5737e494317c76ca (patch)
tree81d7ffad393413e034cae9708663d28bde44bc7e /dev-python
parentVersion Bump (diff)
downloadhistorical-f703c6ccc732145907211d7b5737e494317c76ca.tar.gz
historical-f703c6ccc732145907211d7b5737e494317c76ca.tar.bz2
historical-f703c6ccc732145907211d7b5737e494317c76ca.zip
fix license/repoman
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/csv/csv-0.5.0.ebuild16
-rw-r--r--dev-python/csv/csv-1.0.ebuild12
-rw-r--r--dev-python/epydoc/epydoc-1.1.ebuild28
-rw-r--r--dev-python/gadfly/gadfly-1.0.0.ebuild8
-rw-r--r--dev-python/ldaptor/ldaptor-0.0.6.ebuild13
-rw-r--r--dev-python/log4py/log4py-1.1.ebuild21
-rw-r--r--dev-python/mysql-python/mysql-python-0.9.2-r1.ebuild33
-rw-r--r--dev-python/mysql-python/mysql-python-0.9.2.ebuild23
-rw-r--r--dev-python/pyOpenSSL/pyOpenSSL-0.5.1.ebuild62
-rw-r--r--dev-python/pyframer/pyframer-0.2.ebuild7
-rw-r--r--dev-python/pygtk/pygtk-0.6.11.ebuild5
-rw-r--r--dev-python/pygtk/pygtk-0.6.9.ebuild29
-rw-r--r--dev-python/pygtk/pygtk-1.99.13-r1.ebuild21
-rw-r--r--dev-python/pygtk/pygtk-1.99.16.ebuild15
-rw-r--r--dev-python/pygtk/pygtk-1.99.17.ebuild15
15 files changed, 135 insertions, 173 deletions
diff --git a/dev-python/csv/csv-0.5.0.ebuild b/dev-python/csv/csv-0.5.0.ebuild
index bda58d69e90b..93b5963e0c38 100644
--- a/dev-python/csv/csv-0.5.0.ebuild
+++ b/dev-python/csv/csv-0.5.0.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/csv/csv-0.5.0.ebuild,v 1.6 2003/07/12 12:49:25 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/csv/csv-0.5.0.ebuild,v 1.7 2003/08/07 02:33:10 vapier Exp $
-S="${WORKDIR}/${PN}"
+inherit distutils
DESCRIPTION="CSV Module for Python"
-SRC_URI="http://www.object-craft.com.au/projects/csv/download/csv-0.5.tar.gz"
HOMEPAGE="http://www.object-craft.com.au/projects/csv/"
+SRC_URI="http://www.object-craft.com.au/projects/csv/download/csv-0.5.tar.gz"
-IUSE=""
-KEYWORDS="x86 ~alpha ~ppc ~sparc"
-DEPEND="virtual/python"
LICENSE="PYTHON"
SLOT="0"
+KEYWORDS="x86 ~alpha ~ppc ~sparc"
-inherit distutils
+DEPEND="virtual/python"
+
+S="${WORKDIR}/${PN}"
src_compile() {
distutils_src_compile
diff --git a/dev-python/csv/csv-1.0.ebuild b/dev-python/csv/csv-1.0.ebuild
index 9bab01bc3347..f6bfbd2bea99 100644
--- a/dev-python/csv/csv-1.0.ebuild
+++ b/dev-python/csv/csv-1.0.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/csv/csv-1.0.ebuild,v 1.4 2003/06/22 12:15:59 liquidx Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/csv/csv-1.0.ebuild,v 1.5 2003/08/07 02:33:10 vapier Exp $
inherit distutils
DESCRIPTION="CSV Module for Python"
-SRC_URI="http://www.object-craft.com.au/projects/csv/download/${P}.tar.gz"
HOMEPAGE="http://www.object-craft.com.au/projects/csv/"
+SRC_URI="http://www.object-craft.com.au/projects/csv/download/${P}.tar.gz"
-IUSE=""
-KEYWORDS="x86 ~alpha ~ppc ~sparc"
-DEPEND="virtual/python"
LICENSE="PYTHON"
SLOT="0"
+KEYWORDS="x86 ~alpha ~ppc ~sparc"
+
+DEPEND="virtual/python"
diff --git a/dev-python/epydoc/epydoc-1.1.ebuild b/dev-python/epydoc/epydoc-1.1.ebuild
index 9b1f977c936d..b611162f6647 100644
--- a/dev-python/epydoc/epydoc-1.1.ebuild
+++ b/dev-python/epydoc/epydoc-1.1.ebuild
@@ -1,28 +1,24 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/epydoc/epydoc-1.1.ebuild,v 1.5 2003/06/22 12:15:59 liquidx Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/epydoc/epydoc-1.1.ebuild,v 1.6 2003/08/07 02:33:54 vapier Exp $
inherit distutils
-S=${WORKDIR}/${P}
-DESCRIPTION=" Epydoc is a tool for generating API documentation for Python modules, based on their docstrings."
-SRC_URI="mirror://sourceforge/epydoc/${P}.tar.gz"
+DESCRIPTION="tool for generating API documentation for Python modules, based on their docstrings"
HOMEPAGE="http://epydoc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/epydoc/${P}.tar.gz"
+
LICENSE="MIT"
SLOT="0"
-RDEPEND="virtual/python"
-DEPEND="$DEPEND"
KEYWORDS="x86"
-IUSE=""
+
+RDEPEND="virtual/python"
src_install() {
- distutils_src_install
+ distutils_src_install
- # copy docs (using cp -r cuz of some sub-dirs)
- cp -r ${S}/doc/* ${D}/usr/share/doc/${P}/
-
- # man-pages
- doman ${S}/man/*
-
+ # copy docs (using cp -r cuz of some sub-dirs)
+ cp -r ${S}/doc/* ${D}/usr/share/doc/${PF}/
+ prepalldocs
+ doman ${S}/man/*
}
-
diff --git a/dev-python/gadfly/gadfly-1.0.0.ebuild b/dev-python/gadfly/gadfly-1.0.0.ebuild
index 3b5ccae2ba19..142dabcb11d4 100644
--- a/dev-python/gadfly/gadfly-1.0.0.ebuild
+++ b/dev-python/gadfly/gadfly-1.0.0.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gadfly/gadfly-1.0.0.ebuild,v 1.6 2003/06/22 12:15:59 liquidx Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gadfly/gadfly-1.0.0.ebuild,v 1.7 2003/08/07 02:34:09 vapier Exp $
DESCRIPTION="relational database system implemented in Python"
-SRC_URI="mirror://sourceforge/gadfly/${P}.tar.gz"
HOMEPAGE="http://gadfly.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gadfly/${P}.tar.gz"
-SLOT="0"
KEYWORDS="x86"
+SLOT="0"
LICENSE="BSD"
DEPEND="virtual/python"
diff --git a/dev-python/ldaptor/ldaptor-0.0.6.ebuild b/dev-python/ldaptor/ldaptor-0.0.6.ebuild
index 57299cc9af58..29e53567f888 100644
--- a/dev-python/ldaptor/ldaptor-0.0.6.ebuild
+++ b/dev-python/ldaptor/ldaptor-0.0.6.ebuild
@@ -1,25 +1,24 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ldaptor/ldaptor-0.0.6.ebuild,v 1.6 2003/06/22 12:15:59 liquidx Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ldaptor/ldaptor-0.0.6.ebuild,v 1.7 2003/08/07 02:34:34 vapier Exp $
DESCRIPTION="set of LDAP utilities for use from the command line"
-SRC_URI="http://twistedmatrix.com/users/tv/ldaptor/${PN}_${PV}.tar.gz"
HOMEPAGE="http://twistedmatrix.com/users/tv/ldaptor/"
+SRC_URI="http://twistedmatrix.com/users/tv/ldaptor/${PN}_${PV}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="x86 ~alpha ~sparc"
-IUSE=""
DEPEND=">=dev-python/twisted-1.0.1-r1"
src_compile() {
python setup-ldaptor-utils.py build || \
- die "compilation of ldaptor-utils failed"
+ die "compilation of ldaptor-utils failed"
python setup-ldaptor-webui.py build || \
- die "compilation of ldaptor-webui failed"
+ die "compilation of ldaptor-webui failed"
python setup-python-ldaptor.py build || \
- die "compilation of python-ldaptor failed"
+ die "compilation of python-ldaptor failed"
}
src_install() {
diff --git a/dev-python/log4py/log4py-1.1.ebuild b/dev-python/log4py/log4py-1.1.ebuild
index f1a978909e8f..2989c893e325 100644
--- a/dev-python/log4py/log4py-1.1.ebuild
+++ b/dev-python/log4py/log4py-1.1.ebuild
@@ -1,21 +1,19 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/log4py/log4py-1.1.ebuild,v 1.5 2003/06/22 12:15:59 liquidx Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/log4py/log4py-1.1.ebuild,v 1.6 2003/08/07 02:34:59 vapier Exp $
+
+inherit distutils
-S=${WORKDIR}/${P}
DESCRIPTION="A python logging module similar to log4j"
-SRC_URI="http://www.its4you.at/downloads/files/${P}.tar.gz"
HOMEPAGE="http://www.its4you.at/english/log4py.html"
+SRC_URI="http://www.its4you.at/downloads/files/${P}.tar.gz"
-DEPEND="virtual/python"
-RDEPEND=""
-IUSE=""
-
-SLOT="0"
-KEYWORDS="x86 ppc sparc "
LICENSE="MIT"
+SLOT="0"
+KEYWORDS="x86 ppc sparc"
-inherit distutils
+DEPEND="virtual/python"
+RDEPEND=""
src_install() {
mydoc="doc/*.* database/* log4py-test.py"
@@ -25,4 +23,3 @@ src_install() {
insinto /etc
doins log4py.conf
}
-
diff --git a/dev-python/mysql-python/mysql-python-0.9.2-r1.ebuild b/dev-python/mysql-python/mysql-python-0.9.2-r1.ebuild
index c5bd2f9151ee..1e4f24a17156 100644
--- a/dev-python/mysql-python/mysql-python-0.9.2-r1.ebuild
+++ b/dev-python/mysql-python/mysql-python-0.9.2-r1.ebuild
@@ -1,34 +1,29 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mysql-python/mysql-python-0.9.2-r1.ebuild,v 1.5 2003/06/22 12:15:59 liquidx Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mysql-python/mysql-python-0.9.2-r1.ebuild,v 1.6 2003/08/07 02:36:33 vapier Exp $
+
+inherit distutils
S=${WORKDIR}/MySQL-python-${PV}
DESCRIPTION="MySQL Module for python"
-SRC_URI="mirror://sourceforge/mysql-python/MySQL-python-${PV}.tar.gz"
HOMEPAGE="http://sourceforge.net/projects/mysql-python/"
-LICENSE="GPL-2"
+SRC_URI="mirror://sourceforge/mysql-python/MySQL-python-${PV}.tar.gz"
+LICENSE="GPL-2"
SLOT="0"
-DEPEND="virtual/python
- >=dev-db/mysql-3.22.19"
KEYWORDS="ppc x86 sparc"
-IUSE=""
-inherit distutils
+DEPEND="virtual/python
+ >=dev-db/mysql-3.22.19"
src_compile() {
- if has_version '>=dev-db/mysql-4.0.10' >& /dev/null
- then
- mv setup.py setup.orig
- sed -e 's/thread_safe_library = YES/thread_safe_library = NO/' \
- setup.orig > setup.py
- fi
- distutils_src_compile
+ if has_version '>=dev-db/mysql-4.0.10' >& /dev/null ; then
+ sed -i 's/thread_safe_library = YES/thread_safe_library = NO/' setup.py
+ fi
+ distutils_src_compile
}
src_install() {
- distutils_src_install
-
- dohtml doc/*
+ distutils_src_install
+ dohtml doc/*
}
-
diff --git a/dev-python/mysql-python/mysql-python-0.9.2.ebuild b/dev-python/mysql-python/mysql-python-0.9.2.ebuild
index 829501456dc1..d7093f83f2d6 100644
--- a/dev-python/mysql-python/mysql-python-0.9.2.ebuild
+++ b/dev-python/mysql-python/mysql-python-0.9.2.ebuild
@@ -1,25 +1,24 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mysql-python/mysql-python-0.9.2.ebuild,v 1.8 2003/06/22 12:15:59 liquidx Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mysql-python/mysql-python-0.9.2.ebuild,v 1.9 2003/08/07 02:36:33 vapier Exp $
+
+inherit distutils
S=${WORKDIR}/MySQL-python-${PV}
-DESCRIPTION="MySQL Module for python"
-SRC_URI="mirror://sourceforge/mysql-python/MySQL-python-${PV}.tar.gz"
+DESCRIPTION="MySQL Module for python"
HOMEPAGE="http://sourceforge.net/projects/mysql-python/"
+SRC_URI="mirror://sourceforge/mysql-python/MySQL-python-${PV}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="ppc x86 sparc"
+
DEPEND="virtual/python
virtual/glibc
>=dev-db/mysql-3.22.19"
RDEPEND=""
-KEYWORDS="ppc x86 sparc "
-IUSE=""
-
-inherit distutils
src_install() {
- distutils_src_install
-
- dohtml doc/*
+ distutils_src_install
+ dohtml doc/*
}
-
diff --git a/dev-python/pyOpenSSL/pyOpenSSL-0.5.1.ebuild b/dev-python/pyOpenSSL/pyOpenSSL-0.5.1.ebuild
index 008ee3ad3a52..389e1f610562 100644
--- a/dev-python/pyOpenSSL/pyOpenSSL-0.5.1.ebuild
+++ b/dev-python/pyOpenSSL/pyOpenSSL-0.5.1.ebuild
@@ -1,50 +1,48 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyOpenSSL/pyOpenSSL-0.5.1.ebuild,v 1.8 2003/07/12 12:49:26 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyOpenSSL/pyOpenSSL-0.5.1.ebuild,v 1.9 2003/08/07 02:38:23 vapier Exp $
-IUSE="tetex"
+inherit distutils
-S=${WORKDIR}/${P}
DESCRIPTION="Python interface to the OpenSSL library"
-SRC_URI="mirror://sourceforge/pyopenssl/${P}.tar.gz"
HOMEPAGE="http://pyopenssl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pyopenssl/${P}.tar.gz"
+
LICENSE="LGPL-2.1"
SLOT="0"
-RDEPEND="virtual/python
- >=dev-libs/openssl-0.9.6g"
-DEPEND="$RDEPEND
- tetex? ( >=dev-tex/latex2html-2002.2 )"
KEYWORDS="x86"
+IUSE="tetex"
-inherit distutils
+RDEPEND="virtual/python
+ >=dev-libs/openssl-0.9.6g"
+DEPEND="${RDEPEND}
+ tetex? ( >=dev-tex/latex2html-2002.2 )"
src_compile() {
- distutils_src_compile
-
- if [ "`use tetex`" ] ; then
- cd ${S}/doc
- make html ps dvi
- fi
+ distutils_src_compile
+ if [ "`use tetex`" ] ; then
+ cd ${S}/doc
+ make html ps dvi
+ fi
}
src_install() {
- distutils_src_install
-
- if [ "`use tetex`" ] ; then
- dohtml ${S}/doc/html/*
- dodoc ${S}/doc/pyOpenSSL.*
- fi
-
- # install examples
- dodir /usr/share/doc/${PF}/examples/simple
- insinto /usr/share/doc/${PF}/examples
- doins ${S}/examples/*
- insinto /usr/share/doc/${PF}/examples/simple
- doins ${S}/examples/simple/*
+ distutils_src_install
+
+ if [ "`use tetex`" ] ; then
+ dohtml ${S}/doc/html/*
+ dodoc ${S}/doc/pyOpenSSL.*
+ fi
+
+ # install examples
+ docinto examples
+ dodoc ${S}/examples/*
+ docinto examples/simple
+ dodoc ${S}/examples/simple/*
}
pkg_postinst() {
- echo
- einfo "For docs in html you need to have tetex in your USE var"
- echo
+ echo
+ einfo "For docs in html you need to have tetex in your USE var"
+ echo
}
diff --git a/dev-python/pyframer/pyframer-0.2.ebuild b/dev-python/pyframer/pyframer-0.2.ebuild
index 8efde132dca3..b74298bb1e14 100644
--- a/dev-python/pyframer/pyframer-0.2.ebuild
+++ b/dev-python/pyframer/pyframer-0.2.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyframer/pyframer-0.2.ebuild,v 1.7 2003/07/12 12:49:26 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyframer/pyframer-0.2.ebuild,v 1.8 2003/08/07 02:39:48 vapier Exp $
inherit distutils
DESCRIPTION="Python interface for framerd"
-SRC_URI="http://twistedmatrix.com/users/washort/pyframer/${P}.tar.gz"
HOMEPAGE="http://twistedmatrix.com/users/washort/pyframer/"
+SRC_URI="http://twistedmatrix.com/users/washort/pyframer/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="x86"
-IUSE=""
DEPEND="virtual/python
>=dev-db/framerd-2.4.3"
diff --git a/dev-python/pygtk/pygtk-0.6.11.ebuild b/dev-python/pygtk/pygtk-0.6.11.ebuild
index e1eaeee13c32..a657b30d7aea 100644
--- a/dev-python/pygtk/pygtk-0.6.11.ebuild
+++ b/dev-python/pygtk/pygtk-0.6.11.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-0.6.11.ebuild,v 1.9 2003/06/22 12:15:59 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-0.6.11.ebuild,v 1.10 2003/08/07 02:41:58 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="GTK+ bindings for Python"
-SRC_URI="ftp://ftp.gtk.org/pub/gtk/python/v1.2/${P}.tar.gz"
HOMEPAGE="http://www.daa.com.au/~james/pygtk/"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/python/v1.2/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="1.2"
diff --git a/dev-python/pygtk/pygtk-0.6.9.ebuild b/dev-python/pygtk/pygtk-0.6.9.ebuild
index 9299d33cc099..796d250f204e 100644
--- a/dev-python/pygtk/pygtk-0.6.9.ebuild
+++ b/dev-python/pygtk/pygtk-0.6.9.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-0.6.9.ebuild,v 1.12 2003/06/22 12:15:59 liquidx Exp $
-
-S=${WORKDIR}/${P}
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-0.6.9.ebuild,v 1.13 2003/08/07 02:41:58 vapier Exp $
DESCRIPTION="GTK+ bindings for Python"
-
+HOMEPAGE="http://www.daa.com.au/~james/pygtk/"
SRC_URI="ftp://ftp.gtk.org/pub/gtk/python/${P}.tar.gz"
-HOMEPAGE="http://www.daa.com.au/~james/pygtk/"
+LICENSE="LGPL-2.1"
+SLOT="1.2"
+KEYWORDS="x86 ppc sparc alpha"
DEPEND="virtual/python
>=gnome-base/libglade-0.17-r6
@@ -17,24 +17,15 @@ DEPEND="virtual/python
( >=x11-libs/gtk+-1.2.10
<x11-libs/gtk+-2.0.0 )"
-KEYWORDS="x86 ppc sparc alpha"
-LICENSE="LGPL-2.1"
-SLOT="1.2"
-
src_compile() {
-
./configure --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --prefix=/usr \
- --with-libglade-config=/usr/bin/libglade-config \
- --host=${CHOST} || die
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --with-libglade-config=/usr/bin/libglade-config \
+ --host=${CHOST} || die
emake || die
}
-src_install () {
-
+src_install() {
make prefix=${D}/usr install || die
-
-# make DESTDIR=${D} install || die
}
-
diff --git a/dev-python/pygtk/pygtk-1.99.13-r1.ebuild b/dev-python/pygtk/pygtk-1.99.13-r1.ebuild
index 454cd5e68b56..f412fcbd8688 100644
--- a/dev-python/pygtk/pygtk-1.99.13-r1.ebuild
+++ b/dev-python/pygtk/pygtk-1.99.13-r1.ebuild
@@ -1,37 +1,32 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-1.99.13-r1.ebuild,v 1.8 2003/06/22 12:15:59 liquidx Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-1.99.13-r1.ebuild,v 1.9 2003/08/07 02:41:58 vapier Exp $
# since its a development version
inherit debug
-S=${WORKDIR}/${P}
-DESCRIPTION="GTK+2 bindings for Python"
-SRC_URI="ftp://ftp.gtk.org/pub/gtk/python/v2.0/${P}.tar.gz"
+DESCRIPTION="GTK+2 bindings for Python"
HOMEPAGE="http://www.daa.com.au/~james/pygtk/"
-LICENSE="LGPL-2.1"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/python/v2.0/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="2.0"
KEYWORDS="x86 ~ppc sparc alpha"
-
DEPEND=">=dev-lang/python-2.2
>=x11-libs/pango-1.0.0
>=gnome-base/libglade-2.0.0
opengl? ( >=x11-libs/gtkglarea-1.99.0 )"
-SLOT="2.0"
-
src_compile() {
-
./configure --prefix=/usr/ \
--enable-thread \
- --host=${CHOST} || die
+ --host=${CHOST} || die
emake || die
}
-src_install () {
+src_install() {
make prefix=${D}/usr install || die
-
dodoc AUTHORS COPYING ChangeLog INSTALL MAPPING NEWS README THREADS TODO
}
diff --git a/dev-python/pygtk/pygtk-1.99.16.ebuild b/dev-python/pygtk/pygtk-1.99.16.ebuild
index 9c4c06d6d77c..0b99c08033f9 100644
--- a/dev-python/pygtk/pygtk-1.99.16.ebuild
+++ b/dev-python/pygtk/pygtk-1.99.16.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-1.99.16.ebuild,v 1.5 2003/08/01 16:13:39 foser Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-1.99.16.ebuild,v 1.6 2003/08/07 02:41:58 vapier Exp $
# since its a development version
inherit debug gnome.org
-IUSE="gnome opengl"
-
DESCRIPTION="GTK+2 bindings for Python"
#SRC_URI="ftp://ftp.gtk.org/pub/gtk/python/v2.0/${P}.tar.gz"
HOMEPAGE="http://www.daa.com.au/~james/pygtk/"
-LICENSE="LGPL-2.1"
+LICENSE="LGPL-2.1"
+SLOT="2.0"
KEYWORDS="x86 ~ppc ~sparc ~alpha"
+IUSE="gnome opengl"
DEPEND=">=dev-lang/python-2.2
>=x11-libs/pango-1
@@ -22,16 +22,13 @@ DEPEND=">=dev-lang/python-2.2
gnome? ( >=gnome-base/libglade-2 )
opengl? ( >=x11-libs/gtkglarea-1.99 )"
-SLOT="2.0"
-
src_compile() {
econf --enable-thread || die
emake || die
}
-src_install () {
+src_install() {
einstall || die
-
dodoc AUTHORS COPYING ChangeLog INSTALL MAPPING NEWS README THREADS TODO
}
diff --git a/dev-python/pygtk/pygtk-1.99.17.ebuild b/dev-python/pygtk/pygtk-1.99.17.ebuild
index 4a15402f62ce..fe01aa9b266c 100644
--- a/dev-python/pygtk/pygtk-1.99.17.ebuild
+++ b/dev-python/pygtk/pygtk-1.99.17.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-1.99.17.ebuild,v 1.1 2003/08/01 16:13:39 foser Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-1.99.17.ebuild,v 1.2 2003/08/07 02:41:58 vapier Exp $
# since its a development version
inherit debug gnome.org
-IUSE="gnome opengl"
-
DESCRIPTION="GTK+2 bindings for Python"
HOMEPAGE="http://www.daa.com.au/~james/pygtk/"
-LICENSE="LGPL-2.1"
+LICENSE="LGPL-2.1"
+SLOT="2"
KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE="gnome opengl"
DEPEND=">=dev-lang/python-2.2
>=x11-libs/pango-1
@@ -21,16 +21,13 @@ DEPEND=">=dev-lang/python-2.2
gnome? ( >=gnome-base/libglade-2 )
opengl? ( >=x11-libs/gtkglarea-1.99 )"
-SLOT="2"
-
src_compile() {
econf --enable-thread || die
emake || die
}
-src_install () {
+src_install() {
einstall || die
-
dodoc AUTHORS COPYING ChangeLog INSTALL MAPPING NEWS README THREADS TODO
}